Phone won't detect SIM card


New Member
Dec 4, 2012
Reaction score
Hi everybody. I recently purchased a slightly used Razr Maxx off of eBay - I won't say who the seller was, as they haven't tried to screw me over, but they have well over 100,000 feedback, and almost 100% positive, so I figured they were trustworthy. I wanted to upgrade, but I don't have one available on my plan for a while, so the price seemed very good (about $280) considering the retail price. I currently have a Droid 3. The Razr Maxx came in the mail today, and I took it by my local Verizon store to get it activated. When we inserted the SIM card and turned on the phone, it said to "Please insert the SIM card and turn the phone on". We didn't think much of it, assuming the card was faulty, and got a new one. This time we had to call Verizon support to activate it, but the phone displayed the same message, as if there wasn't a SIM card inserted. The Verizon rep on the phone said that there's probably something wrong with the SIM reader. So I guess my question is this: is it possible that this is what's wrong with it? I know the Verizon person helping us inserted the SIM card the correct way - I looked it up online to double check. Could both of the SIM cards be faulty? I'm not worried about getting my money back; if for some reason the company I purchased the phone from refused to give me money, I know eBay would help me. The listing said it was used, but tested to be fully functional. Also, the company doesn't do replacements, so I could only get my money back. I did buy a 1-year warranty on the phone, but it won't become active until 45 days after the purchase. So yeah, I'm just frustrated, but not mad at anybody who I've dealt with, they've all tried to help me. Thanks in advance for any help/advice, and sorry if this post rambles on a little bit.

UPDATE, 1 DAY LATER: I don't know if this will help anybody else, but I solved the problem. When I was running the intial setup, I was choosing English as the language, as it's my native language. Doing this would give me the "Insert SIM card" message. I decided to click on the only other language - Spanish - and instead of an error message, it said "Congratulations, your phone is activated" (in Spanish). I then went to settings and changed the language to English, and everything is working fine now. This may not be relevant to anybody else that has this problem, but I thought I would share what worked for me.
Last edited: