MTP driver failed install, please help!!


Sep 4, 2010
Reaction score
Lake Elsinore Ca
I tried upgrading my motorola drivers to 4.7.1 and now when I plug my droid2 into my computer the mtp driver keeps trying to install, sometimes it installs successfully and it just loops back into the driver install. I am running vista and have tried everything, re-installing, downgrading to my last driver, numerous restarts and battery pulls, scouring the forums.... Nothing, please help me.
Did you root your Droid, and then rename or get rid of "bloatware" in the Apps directory? If so, rename or restore the MediaSync.apk file on your Droid. I found out the MTP service on your PC won't properly install if this file is altered on the phone.
I actually had fission running then I went back to stock rooted and plugged in my phone and the driver fail was no more, I reinstalled fission among other roms and it hasn't happened since. Thanks for the fix, it will come in handy later because I'm sure I'll find a way to screw it up again somehow.