Missing LTE in Baseband


New Member
Mar 24, 2011
Reaction score
I was hoping someone can help me. I followed Matt’s instructions on flashing the December JB leak with root. It worked great since January until recently…I’m not sure what happened but I lost the LTE part of my Baseband. Now I have can’t get 4G. I tried following someone’s instructions which included using RSD to flash an older ROM (was supposed to correct my baseband). …ended up bricking my Razr. I managed to restore to stock JB using the latest droid utility at this link: http://www.droidforums.net/forum/dr...2-jellybean-windows-mac-linux-all-in-one.html using option 1….still missing LTE in my baseband. I’ve been trying to figure this out for over a month. Does anyone have any ideas?

Thank you in advance for any suggestions.


System version

Android version

Baseband version
Seeing that you lost the LTE Band, the easiest way possibly that I know of to get it back would be to go into the test settings. To do this go to your phone dial pad and enter the following code *#4636#* this will bring you to the Testing menu. Be very careful with the settings in here as not only could you possibly lose LTE, but you can lose other settings that are as important or even more important. I would suggest going into the first one that is labeled "Phone information" at the top of the screen you should see your IMEI and Phone number, go down the page to "Set preferred network type:" the default network type should be "LTE/CDMA/EvDo/GSM/WCDMA" if you happen to have a different setting, first write down the current setting you have, then select the setting and try the one that I have listed. I am posting screenshots to assist in what you should find.

View attachment 64092 View attachment 64093
Thanks for the reply. I did the *#*#4636#*#* and my preferred network type is lte/CDMA/evdo/gsm/wcdma.
Thanks for the reply. I did the *#*#4636#*#* and my preferred network type is lte/CDMA/evdo/gsm/wcdma.

Go back into Test Mode> go into Phone Information> make sure that the preferred network type is the same as you have it listed above, and scroll to the top of the screen and select Run Ping test, if Ping IpAddr fails this is normal, Lat and Long should not be fully displayed, make sure Network type is LTE. If all checks out then LTE is a Band.
My network type in my network settings is lte/CDMA and i made sure the preferred network type is as stated earlier...I ran the ping test and got what you said.....but I noticed on the ping test my gsm service says in service...i should CDMA...not gsm. Any ideas?

Sent from my DROID RAZR using Tapatalk 2
Your screenshot network type shows LTE... my network type says eHRPD

Sent from my DROID RAZR using Tapatalk 2

Your screenshot network type shows LTE... my network type says eHRPD

Sent from my DROID RAZR using Tapatalk 2

Not to worry here. While my screen displays LTE and your screen displays eHRPD, this is providing you with more information that is helpful in understanding what is taking place here. With the signal eHRPD which is actually 3G it overlaps the LTE signal, which eHRPD does this so that you constantly have data coverage, when you slip outside the radius of LTE. Understand that you are in the correct settings with your modem, that is when you confirmed that your device reads, "LTE/CDMA/EvDo/GSM/WCDMA" which actually EvDO is commonly referred to as 3G data/also eHRPD. So, your radio is fine and functioning the way it is suppose to. Which when you step into a LTE area, if the radio does not update automatically, use a signal refresh to update the radio and hopefully change the Verizon tower in your area. Here is the code> go into your dial pad and enter *228 then hit the call button, and signal is refreshed. Here is one more signal refresh that may be helpful *22899 then hit the call button, this will force an update to the next Verizon tower.
Last edited:
I tried the *228 and *22899 and received confirmation on both. I'm still stuck on 3g. I am close to Boston and have always had a strong 4g signal.

I don't know if this matters but my baseband version in the about phone section is missing the lte portion. After browsing around the forums i found a lot of people with the same thing and they also can't access 4g.....there is no resolution that I can find for this
I can't help but wonder, and with my device I cannot try this app, as it was not designed for my phone. I wonder if this could be helpful, again I don't own the device so I can't test or confirm it, but here is a link for an older application to Restore Connectivity Settings.
Thank you for all your suggestions

When I go to the app in the store it says your device isn't compatible.