manage search history


New Member
Oct 30, 2010
Reaction score
Hi, I'm having trouble clearing my Google Search History. On the phone, I hit the magnifying glass button on the lower right side to bring up the google search. Then I hit the menu button and it gives me two options, (1) search settings and (2) manage search history (with a little wrench). However, it will not let me activate that button for some reason. Is there any way to get that activated, or another shortcut to clear the history? I already went into the browser settings and deleted all history, but the google search history still remains. Thank you for any help you can provide.

When I click on the search box on google home page, it brings a dropdown box with all my search history, and at the bottom there is a blue link that says "clear search history." Try that.

Sent from my DROID3 using DroidForums
Actually I looked and it just says clear history.

Sent from my DROID3 using DroidForums
would you mind walking me through it? i don't follow. you want me to launch the browser and then go to the google home page? what i'm talking about is just launching the google search with the magnifying glass, without first opening the browser. that's where i want to clear the history, but the one button that clears it won't activate for me.

Have you tried clearing saved searches?
Open browser, go to google page if not deafult
At the bottom it says settings
From there you can clear saved searches and choose not to save search history.
See if that helps
Don't forget to click save when done

Sent from my DROID2 using Tapatalk
Found out how to activate the manage search history button

Press the search button>menu>search settings>google search>put a check next to search history

Sent from my DROID2 using Tapatalk
thank you! all of your suggestions worked. i appreciate the feedback.

I have never used the search button until just now after reading ur post. I followed your instructions and I can hit the manage history button and I am taken to the Google sign in page, where I log in and and am then taken to HTTPS:// . If you can not get there from the search button just type the link into your browser and you can manage the history. Sorry, I have no solution for why the "wrench" button does not work on ur phone.