Gingerbread leak on D2 SD corruption


New Member
Nov 15, 2010
Reaction score
I'm stumped with an SD problem with my new rom. I updated my D2 to GB using these instructions here:

Actually, I did it something like 12 times trying to work out different issues. The only issue I currently have is that whatever the android OS is using to map the SD card seems to be corrupted after using the rom for a while. It works ok when first loaded, or when the app data is wiped, or the phone is reset. But after a while of using it, the files begin to either look corrupted, or appear to disappear in the file manager. When the files appear corrupted, the browser is no longer able to download files, and installing apps from the market cause the phone to immediately crash and reboot.

When this happens, if I were to pull the sd card out of the phone, and read from card reader in a computer, the files and filesystem look normal and intact with no issues. Running a scandisk on the sd reveals no issues. Also many apps that store data on the SD card work just fine.

I also tried different SD cards, wiped app data, formatted the sd card & tried different combinations of reloading ROMs several times with the same results.

It's been very intermittent. I think it might be happening when using the stock file manager, but not sure.

Anybody have anything to say about this?

Sent from my DROID2 using DroidForums
Actually programs that use the sd card don't always work. I found that the card reader works sometimes, and sometimes doesn't. It just dawned on me that maybe the card controller is possibility overheating? I'm using class 6 8Gig cards. They worked fine with the stock rom, but maybe the new driver is causing the controller to use more power? I wonder if slower speed cards work ok?

Sent from my DROID2 using DroidForums
The type of cards I was using were two different 8Gig Class 6 Lexar cards. I put a 4Gig Class 4 Sandisk, took almost twice as long to transfer all my misic and files with the card in the phone connected to the pc using mass storage system. When using the card from the phone, however, I noticed an immediate speed improvement & things that seemed to simply stop working in the past such as the tasker backup/restore simply started working. Maybe it's fixed with a slower card.

Sent from my DROID2 using DroidForums
To be honest I would try and SBF and see how it works on stock. If you are still having issues then you are ready to send it back right there anyway. If it works then you can try and flash another ROM and see how that goes.
I have SBF'ed to stock and tested about 12 times, and it works just fine with the stock rom. This has taken me about a week of testing so far.

Which other rom would you reccomend for GB? I wasn't aware of any other D2 GB roms.

Sent from my DROID2 using DroidForums
Last edited:
I don't think it was an issue of the controller chip using more power, I think it might be some kind of an SD card cache buffer overrun bug.

Sent from my DROID2 using DroidForums
Looks like I forgot to post that this was fixed by using a slower SD card. Class 6 cards don't work, class 4 and below do work. Driver bug.

Sent from my DROID2 using DroidForums