Droid won't turn on unless plugged into charger first.

josh.zechman

Member
Joined
Jul 30, 2010
Messages
74
Reaction score
0
So I have an OG droid and it will not turn on unless I plug it in on the charger. Once I plug it in it is still unresponsive, then it will turn on to the boot logo. From there I can unplug it, pull the battery and it will turn on and work. It will power off at some point and start the whole process again. I am rooted stock FRG83G. Anyone have any ideas why this is happenening?

Thanks.

Sent from my malfunctioning Droid using DroidForums
 
similar issues

Im having a similar issue. I tried installing a new rom last night and had to wipe davlik which i never had to do before? (This is my 5th rom installment-rom manager) Now its not turning on if i do get it to come on it freezes at the "M" wont let me get into save mode. Its also no longer charging or turning on when its plugged in..Tried removing the battery multiple times but to no avail! any ideas? -Moto Droid
 
Sounds like you both have some battery issues.

Are you able to get into recovery?

Sent from my RZRecovery'd Overclocked, and ROM'd Droid.
 
Well I got mine to work, the battery was okay I pulled the battery and used it in my everyday droid. (This one was my tinker with droid). I did some more research and found out there are some issues with contacts not getting a charge from the battery? So I tore the phone apart cleaned everything ( had dust behind screen) and now it works again, but for how long who knows?? Thanks for the help though..seems I must have stumped everyone with my problem.

Sent from my Droid using DroidForums
 
Back
Top