Data issues while tethering


New Member
Feb 25, 2011
Reaction score
Hello, folk!

For a while now, I have been having data transfer issues while tethering with my phone. It seems primarily to be connected to my computer, oddly enough, and has little to do with my phone.

At first, I used PDAnet on an un-rooted Motorola Droid 1 with Windows Vista. Sometime around Thanksgiving, I was told about rooting Droid devices, and immediately jumped on the bandwagon once I read up about it. I used a Market App that automatically rooted it for me. I then tried out a few ROMs and finally settled into what I am currently using to tether. Here is what my phone looks like now:

Motorola Droid 1 Froyo
PRL 65169
CDMA - EvDo rev. A

The following quote is just a more detailed form of the small summary posted below it. The quoted text includes far more specific details regarding the OSes, but to make it easier I made a tl;dr version.

After I rooted, my phone's tethering through PDAnet worked absolutely fine, but since I could not buy the full access version of PDAnet, I looked into other solutions with wired tethering and found out that my rooted droid had the innate ability to tether. I used that, and it also worked absolutely fine - going an average of 12-15 hours before getting a disconnect, and when it did, it automatically reconnected instantly without me needing to do anything.

After toying around some more with the built-in tethering, I found out that it also worked on Linux, which is my preferred OS but lacking an Internet connection that worked on it (PDAnet and dial-up being my only choices) I eventually fell back on Vista.

Sometime in early January, I made the move to Fedora 12, but to my dismay, tethering was not so stable. Except, there was a weird little trick that made it work perfectly fine: if I selected and enabled tethering before Fedora completely booted up, my connection would last for most of the day without fail. However, eventually it did die out, and when it did, no matter how many times I reconnected the tether, it would stop working within 30 minutes.

After a while of that, and one of my friends demanding I start playing a game I could not emulate with Wine, I switched back to Vista for convenience, and suddenly, tethering worked absolutely fine, as it did in the past.

Later on, I then tried to switch to XP, and fed it the proper files to use the built-in tethering, but I then came across two issues; the first being that it would always disconnect me within 30 minutes, and the second being that it would eventually BSOD on me. PDAnet did not solve the tethering issue.

I switched back to Vista for a third time, but this time, the Internet connection is not stable. PDAnet usually lasts longer than the built-in tethering, but they both disconnect commonly.

I also managed to test wireless tethering with a friend, using the "Wireless Tethering for Rooted Users" application, or something along those lines. With both Windows 7 and Windows XP, wireless tethering disconnected just as commonly as wired tethering.

Vista - wired tethering worked fine
Fedora 12 - wired tethering was slightly buggy, but worked adequately
Vista - wired tethering worked fine
XP - wired tethering was fatally bad, never stayed connected
Vista - wired tethering does not stay connected
7 - wireless tethering does not stay connected
XP - wireless tethering does not stay connected

A few things I have noticed when tethering drops connection:

- The 3G in the status bar disappears completely. From my observations, whether or not I actually am getting 3G up/down access does not matter to my connection, since with my location I am usually lacking 3G, but when my connection stops working, the 3G just disappears, as if I just received SMS or a Call halting my data connection.

- When the data connection halts, the phone itself no longer can make any data transfers; Market, Browser,, and everything else ceases to work properly. However, SMS and Calls work. Usually, I have to reconnect the tether to solve this issues; ocassionally, the data connection stops permanently until I reboot the device, where it begins to work absolutely fine again.

- Very often, particularly when using PDAnet but sometimes with the built-in tether, the data connection pseudo-stops. I can not browse the Internet, but if I had, say, a Skype Call active, it will continue to work properly, as well as MMOs. New connections are refused, though. Dropping the call or the MMO will not let me back in, however.

- Leaving my phone on 'Stay Awake when charging' has seemingly made things slightly more stable.

I have done a hefty amount of research on this issue; I have found that I am not the only person that runs into this, but most of what I have found as far as "solutions" is for wireless tethering, and very often when dealing with Wi-Fi. I do not normally have Wi-Fi or Bluetooth enabled since my home computer has no wireless card. I have tried a few things to remedy the situation, but nothing has helped.

I have attempted different ROMs:

Sapphire 2.0.2 - done with nearly no extra applications than what the Droid needs to run and tether
CyanogenMod 6.1.2
Froyo Kangerade V5.0.9

I have tinkered with multiple settings regarding data connections, toggling sync, turning wireless networks off, turning off background data completely.. nothing has worked.

Overall, from what I have read on various forums about similar tethering issues, I have found it to be very commonly dependent on the computer, which is why only various handfuls would run into this; my issues regarding tethering being related to my OS with little changes to my phone seems to heavily support this. It is slightly perturbing that this installation of Vista would completely disagree, but then again, this installation of Vista has done odd things that I have never seen Vista do.

Is anybody willing to help me with this issue? Perhaps there is a very stupidly simple solution I overlooked or haven't found? Amijustdoinitrong?




Mar 1, 2010
Reaction score
I have the same problem in every city. Ridiculous there is no answer and now know I'm not the only one. Every 5-10 minutes I get dropped. 3G and the Internet connection disappear entirely. Sometimes you have to turn off pdanet and then cycle through apps and the Internet returns. Sometimes if you just wake the phone it will eventually return, sometimes a reboot is necessary. Whatever it is, June Fabrics will need to address this with an update or some notice on their site.