Corporate email and encryption certs


Silver Member
Jul 13, 2010
Reaction score
Arnold, MD
Current Phone Model
Galaxy S6
The company I work for sometimes has encrypted emails, thus requiring certificates for encryption. I have my corporate email synced to my S6 and I've installed the required email certificates for encryption. Unfortunately, I'm only able to send encrypted messages. When I receive an encrypted message, I tap the option to decrypt the message and it fails stating "No Certificate is installed."

Any ideas as to why this may be, even though I've installed the certificates?
Very good question. I'm going to put an asterisk to my possible answer to your issue. The only reason I know somewhat about end-to-end encryption is because of where I work but only as an end user who occasionally had to troubleshoot it. Any deep troubleshooting, I recommend going to your IT guy.

Anyways, have you tried anything yet to resolve the issue? Don't want to waste your time giving you suggestions you already tried.

I'm assuming your S6 is completely up-to-date. I'll go ahead and give you one step if you haven't done so already. Try reinstalling the cert just in case. Sometimes things can happen during the install that blocks one-way traffic which would only happen when you open those messages on your device and why other people can get your messages.

I would still get your IT guy involved though because every company can sometimes have specific ways to set up encryption that isn't the 'norm' but what I listed above is the simplest thing you can do.
Thanks...I haven't tried anything else yet because, well, I think I've tried just about all I could think of, searched quite a bit online, and thought I'd raise the question here to see if any other suggestions might be out there. I had to reinstall the cert a few times because initially it wouldn't accept the password I had set on it (even though I knew 100% I was typing it correctly on my phone), but then come to find out that I exported the certificates from my work PC incorrectly. After correctly exporting the certs, it did take the password and then they seemed to install correctly. I went to make sure the different options were turned on after installing the certs. But it still keeps saying a certificate is not installed if I try to decrypt an encrypted message.

Here's the real kicker...I am one of the company's "IT guys." LOL. Guess I shouldn't say that too loud huh?

I did go to our network security admin who actually issues the email certs and he said we don't officially support Android devices, they can assist on iPhones (he's a Mac guy), and the only suggestion he had for Android was to download Touchdown and tie my corporate email to that.

But of course I'm stubborn and want to use the native email app on the phone.

Yes, my S6 is all up to date with a stock build, no custom ROM. I've even checked with our help desk crew since they typically assist end users with this stuff. None of them have been able to get it working either, and the one rep said she tried on her phone before and got exactly what I'm getting.

Thank you so far!
Last edited:
I finally got around to revisiting this just now and figured it out. What I ended up doing was turning signing on as well and allowed the appropriate certificates for each action (encrypting and digital signing). Now I am able to read encrypted emails from our Exchange server.