Broke Market Link on Root Explorer and Can't Use!


New Member
Jan 26, 2011
Reaction score
So I was experimenting with breaking a market link in My Backup Pro and forgot that I downloaded the app (root explorer) from Amazon App store when it was .99 cents. Anyway, I broke the link, then tried linking to the regular market later on.....and now I can't use the app at all. When I start root explorer now, it says that I do not own the app and asks me to see details or quit. Also, when I got into Amazon App store it does not show up as paid, and now in the regular market I can uninstall it but NOT reinstall it.

I have tried unistalling, then reinstalling my backup with the same result.

Is there a way to reset the Amazon market or the android market for me to fix this dumb mistake? Or is there a way to change the ownership of the app myself? I would hate to lose the ability to use Root Explorer, as it is such an awesome app. Any help would be appreciated.

Sent from my DROIDX using Tapatalk