Another Droid 2 Stuck At Motorola Screen


New Member
Jan 11, 2011
Reaction score
Hi This is the first time posting on the forums. I have a Droid 2 A955 that I had on version 2.2. It was rooted and had clockwork recovery installed. The OTA update was pushed to my phone (which I didn't want) and failed to install. Since then the phone was not working properly. I wanted to unroot and bring the phone back to stock, but was unable to. Every method I tried from the forum it seemed to fail. At that point I tried to remove/uninstall the clockwork recovery but could not. In desperation I might have accidentally wiped something vital from within clockwork, which brought me to my present "M" state. RSDLite does not recognize my device and I cannot boot into any recovery mode Clockwork, stock or otherwiswe. I have a clockwork backup and an image of my SD card before I began but no way to restore. My ultimate goal is to get my Droid 2 Back to factory. Please anyone help I've attached a screen shot of RSDlite
Last edited: