For the OCD - Stop the home button from waking the screen (And Save Battery)

Discussion in 'Drod2169 - X' started by ShadowfoxXXX, Mar 13, 2011.

  1. paulp04

    paulp04 New Member

    Joined:
    Oct 25, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Got it! Comment out WAKE following home in the sholes_keypad.kl located in /system/usr/keylayout/
    It seems they changed the default file?? Whatever, its fixed!

    Sent via DROID X 2.3.3 OC 1.22ghz on Verizon Wireless
     
    #37 paulp04, May 16, 2011
    Last edited: May 17, 2011
  2. Scallywag1

    Scallywag1 Member

    Joined:
    Oct 21, 2010
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Huh? I'm lost.

    EDIT:
    what you do is in root explorer open sholes in text editor and erase wake from line where home is.
    Thanks a lot dude.....worked perfect! Appreciated!!

    Sent from my Liberty GB v5 DX
     
    #38 Scallywag1, May 16, 2011
    Last edited: May 16, 2011
  3. ShadowfoxXXX

    ShadowfoxXXX Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    #39 ShadowfoxXXX, May 16, 2011
    Last edited: May 16, 2011
  4. jr1421

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thanks shadow! For me, I only needed to edit the sholes file, leaving the cdma_shadow file alone. I thought I edited the sholes kl last time I loaded .595, without any luck, but that may have been b/c I also changed the cdma_shadow file and the permissions of both. Oh well, I'm just glad you definitively found the solution. Thanks again!
     
  5. paulp04

    paulp04 New Member

    Joined:
    Oct 25, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    So i found out why home is defaulted to wake the screen..... the home button is linked to the blutooth voice commands. Now my screen wont wake when i initiate the voice commands from my blutooth making it nearly impossible to make calls while driving........ UGH! Now i got to figure out how to make both work!??! Anyone want to help? I thought the blutooth keyboard layout would take over, but its not the case so far..

    Sent via DROID X 2.2.1 rooted running Rubix Focused 1.9.7 OC 1.22ghz on Verizon Wireless
     
  6. SuperChargedJ

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Does this work on CM7?

    Sent from my DROIDX using DroidForums
     
  7. OnMy2ndGP

    OnMy2ndGP Member

    Joined:
    Sep 27, 2010
    Messages:
    212
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I don't see why not. I'm on Liquid v2.3 which running pretty much the same as CM7 and the manual edits worked for me.

    NOTE: You will also need to edit qwerty.kl too (which is in the same folder as cdma_shadow-keypad.kl)
     
Search tags for this page

android disable home button unlock

,
disable home button unlock
,
disable home key unlocking s4
,
disable home key wake up galaxy s4
,
disable keyboard slide screen wake
,
galaxy s4 prevent home button from waking phone
,
gingerbread home button wake
,
how to disable home button unlock
,
how to disable home button unlock s4
,
stop unlock with home button android