For the OCD - Stop the home button from waking the screen (And Save Battery)

Discussion in 'Drod2169 - X' started by ShadowfoxXXX, Mar 13, 2011.

  1. Scallywag1
    Offline

    Scallywag1 New Member

    Joined:
    Oct 21, 2010
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    0
    i am running liberty 1.5 on dx and just applied this and it works perfectly. Thanks
    For those interested I also have the app mylock running which bypasses the slide to unlock screen. Then I also have screen suite running on system default to go directly to the security lock. I was getting tired of sliding, then imputing password to get into phone.
    this has worked really well for me. the home button was draining my battery bc the screen wouldn't go completely off if the home button was hit while locked.....so thanks
  2. SuperChargedJ
    Offline

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Has anyone tried this hack on the newest Gingerbread rom for the DX?
  3. Scallywag1
    Offline

    Scallywag1 New Member

    Joined:
    Oct 21, 2010
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    0
    Yep....works.

    Sent from my DROIDX using DroidForums
  4. SuperChargedJ
    Offline

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    Indeed it does, even better than before. It must be a gingerbread thing. Thanks for the confirmation.
  5. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    It definitely does work better on GB. Now, when using the widget "No Lock," the hard buttons will not wake the phone even when you have the No Lock widget set to Unlocked. This means, for me, that I can completely bypass the slide-to-unlock screen altogether, and simply press the power button to unlock directly. On froyo, with the No Lock widget set to Unlocked, the hard buttons would still wake the phone (at least it did for me). Now I don't have to use the Antilock app anymore :)
  6. timfromthegym
    Offline

    timfromthegym New Member

    Joined:
    Apr 16, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    SO, I tried to download your file by right clicking, and it took me to an invalid dropbox site. I thought this was the problem, so i tried to download it via a right click of the file... when i right clicked and did "save as" it downloaded the text from the error webpage into the cdma_shadow_keypad.kl.

    I replaced the original file with this error file, and now every button wakes up my phone and there is no lock on the phone whatsoever. It did the complete opposite of what I expected!

    Does anyone have the original cdma_shadow_keypad.kl, or the revised file that ShadowfoXXX put out so that I can have my phone actually have buttons that dont wake.

    This is truly terrible as now when the phone is in my pocket all the hard buttons including the volume rockers and camera wake the phone up and i pocket dial people let alone KILL my batter on the X.

    HELP!

  7. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Here you go - this is the edited one.

    Forgot to mention, after you unzip it and place it in system/usr/keylayout, change the permissions to read/write for user, and just read for group/others. Once you've changed the permissions, reboot before testing it out.
    Last edited: Apr 16, 2011
  8. mebobio
    Offline

    mebobio New Member

    Joined:
    May 25, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    rooted?

    Do you need to be rooted to access the permissions from the root file?
  9. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    I cannot get this procedure to work with gingerbread .591. I've tried editing the .kl file and manipulating the permissions, but the hard buttons still wake my phone. Has anyone else had success with gingerbread .591?
  10. SuperChargedJ
    Offline

    SuperChargedJ New Member

    Joined:
    Feb 15, 2011
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    +1

    This seriously annoyed the crap out of me this morning when I couldn't get it to work. Looking forward to the fix for this as well.
  11. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    *Bump* Has anyone gotten this to work with .591?
  12. Scallywag1
    Offline

    Scallywag1 New Member

    Joined:
    Oct 21, 2010
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    0
    Its driving me crazy!!

    Sent from my Liberty GB v5 DX
  13. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Update - have not been able to get it to work on .595 either. Still looking into it...
  14. ShadowfoxXXX
    Offline

    ShadowfoxXXX New Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Im on it. give me a bit...
  15. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Ok great let us know if you make any progress.
  16. paulp04
    Offline

    paulp04 New Member

    Joined:
    Oct 25, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Ive been looking into this myself and Its puzzling me.... nothing seems to disable the home/wake button.... has anyone had any success?
  17. paulp04
    Offline

    paulp04 New Member

    Joined:
    Oct 25, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    Got it! Comment out WAKE following home in the sholes_keypad.kl located in /system/usr/keylayout/
    It seems they changed the default file?? Whatever, its fixed!

    Sent via DROID X 2.3.3 OC 1.22ghz on Verizon Wireless
    Last edited: May 17, 2011
  18. Scallywag1
    Offline

    Scallywag1 New Member

    Joined:
    Oct 21, 2010
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    0
    Huh? I'm lost.

    EDIT:
    what you do is in root explorer open sholes in text editor and erase wake from line where home is.
    Thanks a lot dude.....worked perfect! Appreciated!!

    Sent from my Liberty GB v5 DX
    Last edited: May 16, 2011
  19. ShadowfoxXXX
    Offline

    ShadowfoxXXX New Member

    Joined:
    Jan 16, 2011
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Last edited: May 16, 2011
  20. jr1421
    Offline

    jr1421 New Member

    Joined:
    Nov 21, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Thanks shadow! For me, I only needed to edit the sholes file, leaving the cdma_shadow file alone. I thought I edited the sholes kl last time I loaded .595, without any luck, but that may have been b/c I also changed the cdma_shadow file and the permissions of both. Oh well, I'm just glad you definitively found the solution. Thanks again!
Search tags for this page

android disable home button unlock

,
disable home button unlock
,
disable home key unlocking s4
,
disable keyboard slide screen wake
,
galaxy s4 prevent home button from waking phone
,
gingerbread home button wake
,
how to disable home button unlock
,
how to disable home button unlock s4
,
how to disable samsung s4 home button from unlocking phone
,
prevent home screen from waking my phone
,
s3 home button wake no root
,
stop unlock with home button android