VPN Connection on Gingergread..

nprez

New Member
Joined
Aug 16, 2010
Messages
29
Reaction score
0
Hello everyone,

Has anyone found a fix for the VPN connection problem in android.
I've been reading around in the net and this thread pretty much reflects, I believe, the current status of this issue on google's side.
Issue 4706 - android - Droid phone PPTP VPN dying after a short while. - Android - An Open Handset Alliance Project - Google Project Hosting

What it's doing for me:
I've tried a couple of free vpn services with no luck: freeusvpn.com, bestfreevpn.com, vpnod.com.
I've also tried both PPTP and L2TP connections.
The connection is established with all those services, but no data is transferred (pretty much matches what other users describe in the google thread).
Some say the problem is solved by not using encryption, but I'm not able to try this as most free VPN servers require it, without it the tunnel will not even be established.

I've also tried a solution I found online which involves replacing the pppd file in /system/bin, and also the ip-up-vpn file inside /system/etc/ppp, with no luck (some have suggested that there might be a problem with the way the pppd file was compiled).

Since google doesn't seem to have done much to solve this vpn bug, has anyone found a fix coming from a developer such as Liquid.
I'm currently running LGB 1.92.

Thanks..
 
Top