Unroot issues


New Member
Sep 7, 2010
Reaction score
I had rooted my phone using easyroot before the update and worked great but now I want to remove the superuser permission icon since I no longer am rooted with the new update. Tried reseting my phone but the superuser icon was still there. What do I do?

Sent from my DROIDX using DroidForums App
need to reroot to remove an app like that bc its installed in the system folder
Ok I kinda guessed I would..... so is there a one click step to rooting droid x 2.2? Does anyone know if easy root works for the droid x 2.2 now?

Sent from my DROIDX using DroidForums App
Thanx it worked flawlessly. Decided to stay rooted tho haha

Sent from my DROIDX using DroidForums App
if you do end up wanting to unroot your phone the easiest way is to download a terminal emulator and then do the following

enter su and the $ should turn into a #

then enter the following commands and press enter

mount -o rw,remount -t ext3 /dev/block/mmcblk1p21 /system

rm /system/app/Superuser.apk ( the S is capitalized)

rm /system/bin/su

rm /system/bin/busybox

mount -o ro,remount -t ext3 /dev/block/mmcblk1p21 /system

then reboot your phone and Super User will be gone.
Ok thanx for the help

Sent from my DROIDX using DroidForums App
Z4root worked flawlessly on my droid x. Haven't tried to unroot yet though.
Just tried z4root, and it appears the phone is now frozen. Can't use any of the hard buttons to get off the screen. I'm kind of afraid to power off or battery pull...