Trouble installing framework-res.apk

7chris crash

New Member
Joined
Jul 9, 2010
Messages
4
Reaction score
0
Thank You So MUCH

I have my phone rooted, I have pulled off the framework-res.apk file and changed a few images maybe like 12 total. I rezip the apk and then I change it back to framework-res.apk then I use the autosign.bat tool i downloaded to resign the app. I then use adb to try and push the framework back onto my phone into /system/framework/ and I get permission denied. am I doing something wrong? I also have tried an install with adb install framework-res.apk and i get this..

C:\androidsdk\tools>adb install C:/androidsdk/pulledapps/framework-res/framework-res.apk

1931 KB/s (2348096 bytes in 1.187s)
pkg: /data/local/tmp/framework-res.apk

Failure [INSTALL_FAILED_ALREADY_EXISTS]

C:\androidsdk\tools>


I have been trying for a couple days all kinds of things to get my framework file altered and I just can't figure it out. Any help would be greatly appreciated.

This is how I do it. Make sure you've got your old one backed up.

adb shell
su
mount -o remount,rw /dev/mtdblock4 /system
dd if=/sdcard/framework-res.apk of=/system/framework/framework-res.apk

When you do these commands, you're replacing a file in use, and android doesn't like that so it'll auto-reboot, but its the way I've always used. Also the if=/sdcard/framework-res.apk just refers to wherever your framework is (this assumes it's on the root of the sdcard).

Thank you so much! I have been trying to get this to work for me for ages and this has solved my problem! You are a lifesaver!!!!!

P.S. I created a batch script to do this for me and added it to the sendto menu. Now its completely automated!
 
Top