Sync Stuck and Draining Battery Bigtime

Chief Wahoo

Premium Member
Premium Member
Joined
Nov 21, 2009
Messages
325
Reaction score
0
Location
South Central PA
I recently updated to 0.6.2 (from 0.5) and the update went well, but I immediately noticed that the sync notification was always present and the battery life has been less than I had expected.

My search came back with this being a common problem (primarily from posts about a year ago) and I have tried turning off the Auto-sync (in Settings>Accounts & sync but the sync symbol still appears in the notification panel. The posts from a year or so ago indicated that the Android System was running at a very high percentage, but mine is running at 17% and the Android OS is at 12% and that was the culprit in draining the battery.

Has anyone else seen this recently? I am at a loss and don't know if it is something BB related or app related, but aside from restoring the same apps that I had on 0.5, I don't recall any settings that would have been sync oriented. The BB0.6.2 is very slick and I don't want to go back to 0.5, but 6 hour battery life is not going to work for me.

Any ideas or areas to check would be appreciated. Would it be worthwhile to reflash 0.6.2 (wipe and the whole 9)?
 

alwerner

Member
Joined
Nov 26, 2009
Messages
119
Reaction score
0
Since you upgraded from v5 to v6, I'm assuming you did a wipe. My guess is that because of this you are experiencing the resync with all of your contacts, calendars, etc. I would give it a day or two to see if the sync's stop.

My first day had a lot of syncing but after that, battery has gotten better.
 
OP
C

Chief Wahoo

Premium Member
Premium Member
Joined
Nov 21, 2009
Messages
325
Reaction score
0
Location
South Central PA
Thanks, I ended up reflashing the ROM and was much more watchful in terms of the apps that I restored from Titanium Backup and I haven't seen the sync symbol show up, but then again, I haven't accessed gmail yet, which would kick off a sync function (I believe). . . so I will be patient and see if the battery stabilizes after a couple of days. What is interesting is that of the various gmail options (picasa, calendar, contacts and gmail), I only use gmail, so I may just go in and deselect the other sync options to minimize the variables that could cause the sync to get stuck. Just saying.

Thank you for your response.
 

psiuglen

Member
Joined
Jun 8, 2010
Messages
78
Reaction score
0
Location
SE MI
I'm not sure if it's related but the Email program has been killing my battery. This morning I got up, unplugged, about an hour later I was down to 90%. Checking the battery usage, Email had CPU active for around 30 minutes...I have one hotmail and one yahoo account on there! Going to try to track it some more this weekend.

In fact, under Battery History, All Time, Partial Wake usage, it leads at close to 50%. Hmmm....
 
OP
C

Chief Wahoo

Premium Member
Premium Member
Joined
Nov 21, 2009
Messages
325
Reaction score
0
Location
South Central PA
Interesting to read the post on email being a potential culprit - I had not used the email app previously, but set it up over the last couple days and then upgraded to BB0.6.2. . .

I didn't notice the sync notification for a couple of hours today and the battery seemed to be doing a bit better, then I received a few emails (that are linked to the email app) and the next thing I knew my battery dropped from like 76% to 39%.

I guess I will reflash (the third time) the BB0.6.2 and not set up email and see if I still get the sync notification sticking. . . and will update with results shortly.

If it is email (and I am linking to a comcast email box, in case anyone else is Comcast and has experienced a similar issue), I wonder what else I can do with that email account.
 
Top