[ROOT REQUIRED] Solve DROID Wifi Random Drop Issue

roys

New Member
Joined
Jan 14, 2010
Messages
15
Reaction score
0
On my Droid, I had experienced the Wifi random drop issue as described in the thread https://supportforums.motorola.com/thread/16191?start=0&tstart=0.

The situation is, even with the strongest signal (next to the router), my Droid will still randomly drop the connection (wifi icon was shown as connected, but can't surf website), whereas both of my laptops still working flawlessly with the router.

After did some research of the thread mentioned above, I found that the problem is because of Droid wifi will turn into power saving mode after some time, and it can't be controlled by the "Wifi Sleep Policy" since they are different concept. The wifi power saving mode cause the Droid stops the wifi power temporarily, and resumes when need. On some router, it may not support such operation as the router will drop the connection, and finally cause the compatibility problem.

The solution is to turn the Droid wifi power saving off by using the command "wlan_cu". For details, you can read this page: https://supportforums.motorola.com/message/105858;jsessionid=8990D618669CAD49EB83B509F91FF0E7.node0.

Finally, I had wrote an application long time ago, to turn off the wifi power saving mode each time when the wifi connection was established. Since the command is only effect for the current session, so we must apply it each time the connection is established (IP acquired). The application will check if your wifi is turned on and established, and apply it for you every time.

I had used it long time ago and haven't experience the wifi problem again. So to share those hint with you all.

Search the name "DROID/MS WifiPowerSavingOff" or simply "WifiPowerSavingOff".

Remember it requires your Droid/MS to be rooted and grant the "Always" permission in order to use it. Also, it has some compatibility issues across different devices, as someone reports that not supporting Froyo 2.2 yet. BTW, if our device on Froyo 2.2 still have the wifi problem, I will try to update it in order to support in the new version.
 
Last edited:

JonKyu

Silver Member
Joined
Nov 16, 2009
Messages
2,320
Reaction score
0
Location
Provo, UT
Interesting, my droid had this problem as well. But for me I think it was a matter of the distance being too far. my droid works fine now but I'll definitely check out your app. Thanks very informative.

Edit: this doesn't have any Ill effects on battery does it?

Edit 2: just read the description. One comment said it doesn't work on froyo is that true?
Sent from my Tapatalk using Droid
 
OP
R

roys

New Member
Joined
Jan 14, 2010
Messages
15
Reaction score
0
Interesting, my droid had this problem as well. But for me I think it was a matter of the distance being too far. my droid works fine now but I'll definitely check out your app. Thanks very informative.

Edit: this doesn't have any Ill effects on battery does it?

Edit 2: just read the description. One comment said it doesn't work on froyo is that true?
Sent from my Tapatalk using Droid

Reply to your first question, it must have some effect on the battery life, as it turned off the power saving feature of the wifi. However, for me personally, I prefer stable wifi connection rather than battery life. If you really caring about the battery life, you can turn off the "auto check" feature, and perform the operation manually. So, at some time if you want stable wifi, just open the app and click it after your wifi is on. Otherwise, you can have longer battery life.

Since I don't have Froyo installed Droid, so I don't know if it works fine or not. One assumption, if Froyo already fixes the wifi random drop issue, then we no longer need such kind of app. Otherwise, I have to wait until Froyo release on Droid/Milestone, in order to test or update it.

In addition, I don't know any news of rooting on Froyo yet, so I have to wait until.
 

grinchy

Member
Joined
Jan 12, 2010
Messages
714
Reaction score
1
Location
Lakeland,FL
On my Droid, I had experienced the Wifi random drop issue as described in the thread https://supportforums.motorola.com/thread/16191?start=0&tstart=0.

The situation is, even with the strongest signal (next to the router), my Droid will still randomly drop the connection (wifi icon was shown as connected, but can't surf website), whereas both of my laptops still working flawlessly with the router.

After did some research of the thread mentioned above, I found that the problem is because of Droid wifi will turn into power saving mode after some time, and it can't be controlled by the "Wifi Sleep Policy" since they are different concept. The wifi power saving mode cause the Droid stops the wifi power temporarily, and resumes when need. On some router, it may not support such operation as the router will drop the connection, and finally cause the compatibility problem.

The solution is to turn the Droid wifi power saving off by using the command "wlan_cu". For details, you can read this page: https://supportforums.motorola.com/message/105858;jsessionid=8990D618669CAD49EB83B509F91FF0E7.node0.

Finally, I had wrote an application long time ago, to turn off the wifi power saving mode each time when the wifi connection was established. Since the command is only effect for the current session, so we must apply it each time the connection is established (IP acquired). The application will check if your wifi is turned on and established, and apply it for you every time.

I had used it long time ago and haven't experience the wifi problem again. So to share those hint with you all.

Search the name "DROID/MS WifiPowerSavingOff" or simply "WifiPowerSavingOff".

Remember it requires your Droid/MS to be rooted and grant the "Always" permission in order to use it. Also, it has some compatibility issues across different devices, as someone reports that not supporting Froyo 2.2 yet. BTW, if our device on Froyo 2.2 still have the wifi problem, I will try to update it in order to support in the new version.


2.2 wifi fixed?
 
OP
R

roys

New Member
Joined
Jan 14, 2010
Messages
15
Reaction score
0
On my Droid, I had experienced the Wifi random drop issue as described in the thread https://supportforums.motorola.com/thread/16191?start=0&tstart=0.

The situation is, even with the strongest signal (next to the router), my Droid will still randomly drop the connection (wifi icon was shown as connected, but can't surf website), whereas both of my laptops still working flawlessly with the router.

After did some research of the thread mentioned above, I found that the problem is because of Droid wifi will turn into power saving mode after some time, and it can't be controlled by the "Wifi Sleep Policy" since they are different concept. The wifi power saving mode cause the Droid stops the wifi power temporarily, and resumes when need. On some router, it may not support such operation as the router will drop the connection, and finally cause the compatibility problem.

The solution is to turn the Droid wifi power saving off by using the command "wlan_cu". For details, you can read this page: https://supportforums.motorola.com/message/105858;jsessionid=8990D618669CAD49EB83B509F91FF0E7.node0.

Finally, I had wrote an application long time ago, to turn off the wifi power saving mode each time when the wifi connection was established. Since the command is only effect for the current session, so we must apply it each time the connection is established (IP acquired). The application will check if your wifi is turned on and established, and apply it for you every time.

I had used it long time ago and haven't experience the wifi problem again. So to share those hint with you all.

Search the name "DROID/MS WifiPowerSavingOff" or simply "WifiPowerSavingOff".

Remember it requires your Droid/MS to be rooted and grant the "Always" permission in order to use it. Also, it has some compatibility issues across different devices, as someone reports that not supporting Froyo 2.2 yet. BTW, if our device on Froyo 2.2 still have the wifi problem, I will try to update it in order to support in the new version.


2.2 wifi fixed?

I don't have 2.2 to test...
 

PhontomF

Member
Joined
Nov 27, 2009
Messages
212
Reaction score
0
Thanks a lot, seems to be working for me on Froyo BB v0.3
 

takeshi

Silver Member
Joined
Nov 29, 2009
Messages
4,573
Reaction score
0
Interesting, my droid had this problem as well. But for me I think it was a matter of the distance being too far.
In my case it was the router running in mixed mode. Switching to G-only resolved it in my situation.
 

PetRiLJoe

Member
Joined
Mar 28, 2010
Messages
278
Reaction score
1
Location
Opelika, AL
I am experiencing thisand tired of waiting on reconnect, ill have to try this and write back here.
 

JonKyu

Silver Member
Joined
Nov 16, 2009
Messages
2,320
Reaction score
0
Location
Provo, UT
Interesting, my droid had this problem as well. But for me I think it was a matter of the distance being too far.
In my case it was the router running in mixed mode. Switching to G-only resolved it in my situation.
Thanks for that suggestion, I have two routers atm since my router/modem was still giving me problem s. I may designate one for g only. I still have problems on occasion, my droid is the only one of my devices that gives me wifi issues lol


Sent from my Tapatalk using Droid
 
Top