"Removed SD Card"

naman919

Member
Joined
Nov 6, 2009
Messages
561
Reaction score
0
Location
Richmond, VA
I keep having issues with the Droid not reading the SD card upon reboot. It's reading 9/10 times but i'm starting to think it's kernel related.

I got a replacement device b/c I lost mine, and I had an issue where it wouldn't read the SD Card. They sent me a second one and I'm having the same issue.

I'm using two different SD cards b/c they sent me two new units with an SD card each. The second one has been reading the card until i put on CM 5.0.8 and seemingly after i installed the p3 kernel for 1Ghz through Rom Manager. I'm in the process of not installing a kernel and putting 5.0.8 back on then backing up and installing an OC kernel.

I even went and installed the kernel manually through recovery. Rebooted and the SD card error was shown. Anyone else had this happen?

My old Droid had 5.0.8 and the same kernel running just fine. I can't figure out what in the world is going on. I can't imagine I got two brand new droids that BOTH are defective when reading SD cards.

My process is to .sbf, root, install CM, partition SD card, install kernel. Then ERROR. bummer.

*scratches brain*
 

Bob Dammit

Super Moderator
Joined
Dec 11, 2009
Messages
1,708
Reaction score
17
Location
N 42° 05.183 W 079° 10.914
I keep having issues with the Droid not reading the SD card upon reboot. It's reading 9/10 times but i'm starting to think it's kernel related.

I got a replacement device b/c I lost mine, and I had an issue where it wouldn't read the SD Card. They sent me a second one and I'm having the same issue.

I'm using two different SD cards b/c they sent me two new units with an SD card each. The second one has been reading the card until i put on CM 5.0.8 and seemingly after i installed the p3 kernel for 1Ghz through Rom Manager. I'm in the process of not installing a kernel and putting 5.0.8 back on then backing up and installing an OC kernel.

I even went and installed the kernel manually through recovery. Rebooted and the SD card error was shown. Anyone else had this happen?

My old Droid had 5.0.8 and the same kernel running just fine. I can't figure out what in the world is going on. I can't imagine I got two brand new droids that BOTH are defective when reading SD cards.

My process is to .sbf, root, install CM, partition SD card, install kernel. Then ERROR. bummer.

*scratches brain*

Have you tried backing up your card up your card (with a reader) on your computer and reformatting it with your phone then restoring from your computer? There have been issues with cards not reading if they are corrupted, and sometimes a format fixes it.
 

Jas0n

New Member
Joined
Jul 5, 2010
Messages
2
Reaction score
0
Location
Los Angele, CA
The issues is really annoying. The sd card works randomly regardless of how may fat32 re-formats I do to it. Once it's working I have to make sure my phone never ever dies because the sd card will not work after another reboot. I really like SG, I think it's a great rom but it's a pita. I have tested the same card on another droid running 2.2 froyo without formatting it, and it will work every time even if I reboot the phone 10x.

It seems not to effect many users but I'd like to see an update to at least address this issue.
 

fl0w3n

New Member
Joined
May 26, 2010
Messages
1
Reaction score
0
I have the same issue, I actually arrived at this thread because I wanted a more permanent fix.

Here is what I have found fixes the issue on mine after a reboot etc.

1. After the reboot, and the error shows up...do a battery pull. While the battery is out, remove the sd card.
2. Boot phone with no sd card (should say exact same error) now do a NORMAL power down
3. Once the phone has shut dow, replace the sd card, power on - issue is normally fixed for me once I've done this procedure
 
OP
naman919

naman919

Member
Joined
Nov 6, 2009
Messages
561
Reaction score
0
Location
Richmond, VA
this is a bizarre issue and plagues me as well. CM v6.0-RC1 has seemed to fixed the issue, but as indicated above and it being a froyo ROM, i'm still puzzled why it was happening on Eclair ROMs.
 
Top