Recent GPS Problems

droijo

Member
Joined
Apr 27, 2010
Messages
222
Reaction score
3
Hello,

Did a search and did not find any resolved topics. Has anyone been having recent GPS issues? The Nav app works however, it takes forever to connect to a GPS receiver.

Recently, I remember there was an update to google maps and I believe, the nav app. Ever since the update, it seems like I have been having issues. It is taking 5, sometimes 10 minutes to find the receiver.

Has anyone else been having problems and is it temporary for now getting a fix?
 

HarshReality

Member
Joined
Mar 22, 2010
Messages
382
Reaction score
0
Location
Indiana
Wait for 2.2.. basic GPS will be handled by skyhook which is supposed to be much better.

Sent from my Droid using Tapatalk
 
OP
D

droijo

Member
Joined
Apr 27, 2010
Messages
222
Reaction score
3
The Navigation was one of the reasons I bought this phone. Who knows when 2.2 will come out. Please keep me updated valen if you get it to work.

Anyone else has any insight?
 

droid_valen

New Member
Joined
Feb 22, 2010
Messages
7
Reaction score
0
Location
the other destroyed american city
I don't think that fix I posted really helped. I left google maps and GPS logging my trip into work today and It took about 4-5 minutes to acquire a signal. That is much longer then a couple of weeks ago when I last used it.
 

Monshroud

Member
Joined
Apr 9, 2010
Messages
44
Reaction score
0
Location
Colorado
I have had a similar issue and two things that can get you back quickly are either:

1> Put your phone into Airplane mode and then back out of it. This will sometimes reset the GPS, it works about 50% of the time for me.

2> Power your phone off and back on.

That is what works for me, individual results may vary.
 

lazyyamerican

New Member
Joined
Feb 14, 2010
Messages
5
Reaction score
0
I too have loads of trouble connecting all too often with the GPS...seems like it's at an all time high in terms of not wanting to work lately though. Sometimes if I allow it to connect from my 3G, the navigation kicks in but all and all it really needs to get ironed out.
 
OP
D

droijo

Member
Joined
Apr 27, 2010
Messages
222
Reaction score
3
Thanks for the tips guys. It does needs to get a remedy soon.

I've tried everything including turning it off and back on. I haven't tried the airplane mode but will try it the next time.
 

ShowTime

Member
Joined
Jan 25, 2010
Messages
532
Reaction score
0
I've been having problems with this off and on for about 3 weeks or so now, even before the most recent update. I've found that I can usually Back out of the Nav app all the way back to the regular map, then start it again and it seems to connect pretty quick the second time. :confused:
 
Top