Peculiar rintone problem


Jul 17, 2010
Reaction score
I read the forums, and used Easy MP3 Cutter on my Windows XP laptop to rip a 7 second clip from an album to make an mp3 ringtone. Created a 'ringtones' folder on the SD card on the DX as instructed using the USB cable to interface the phone direct to the laptop. Copied the file over, and voila! It showed up in my ringtones list as titled, and I could set it to one of my contacts no problem.

So then I tried it again on a different track/different CD. Cut out a 10 second clip, this one was 108K in size (the other was 70K), followed the exact same procedure. But this time:

When copying the mp3 file to the DroidX 'ringtones' folder on the SD card, an error came up that the file had some kind of problem and the DroidX might not be able to display it in the ringtones list. So I checked the file, opened it with an mp3 editor, played it with multiple players, everything looks completely OK with the file. Tried copying it again, and again the same error.

Is the file too large? Is there a size limit? A length limit? Some other secret sauce I am unfamiliar with? Anyone have any ideas what the problem could be?

new edit: just tried again - edit the ringtone, and the error that is given (in Windows) when copying to the Droid X is "The file has one or more properties outside of device limits. If possible, use a media program that can convert the file before copying it. If you copy the file now, ti will be stored on the device, but may not be presented in the device user interface."

And indeed, it does not show up in the ringtone list. The file size is smaller now - 94K. But obviously, there is something else that the DX does not like about it...

Another try: I used mp3tag utility on the PC to first change all the tags from v1 to v2, then to other formats. Same problem. I then removed all the ID3 tags. Same error. (A web search found someone who believed that this error is caused by improper or corrupt ID3 tags in the mp3 file). So I am pretty much at a complete loss now.

Well. Forcing the file into the SD card leaves the file there with no display in the ringtone menu as before. However - using 'Files' application to locate the file on the SD card, opening the file and playing the sound, then going back to applications and voila! The ringtone shows up in the ringtones menu. This sure looks like a subtle bug in either or both the Motorola driver on the PC to interface the phone to the computer and the handling of the file and the menus on the phone itself. So if anyone else runs into this issue - open the file with the 'Files' app, then try again. Maybe it will fix itself for you also.
Last edited: