Need some serious help with upgrading my droid x to GB


New Member
Aug 19, 2011
Reaction score
Rockford, IL
Ok so first: I apologize if this type of thread is all over the place, but I'm new to the forums and wasn't sure where this should go..

Anyway, I have a dx, and I have spent countless hours trying to get the thing to update the the deodexed all in 1 update in my (purchased) TBH.

My goal: To update from stock 2.3.340 to the latest version of gb, or whatever rubix focused 2.0.1 runs

what I have tried:
**keep in mind that before all of these steps, I have used z4root and had the droid 2 bootstrap (not droid x), and in between all of these failed attempts I have been flashing back to 2.3.340 with 1KDS' linux sbf flasher**

- Updating from stock to the two part installer in tbh - the first file always ends in installation aborted. And yes I make sure to wipe system, data, cache, and mount system before flashing.
- Updating with the all in 1 update (both odexed and deodexed) released in tbh, The odexed version worked once (following the steps listed above) but when I tried to update to the latest so I could flash rubix, I got stuck at the red moto logo on boot for about 45 minutes and sbf'd again.

those are the two that I don't really understand what went wrong.. is there an issue with compatibility in the sbf in 1KDS' disc? I have tried a TON more than what I wrote above, but its way too late for me to get into everything I tried or I might pass out on my keyboard :icon_eek:

Sorry if this post seems a bit unorganized and confusing, but I've been working on this basically all day and I'm just about at my witt's end and too exhausted to come up with an organized paragraph or 2 :icon_frown:

Please help me!! I'm getting desperate

EDIT: After sleeping on it, I followed the guide at on a different computer with an updated rsd lite (4.9) and everything went fine, liberating now!