Laggy Launcher Droid w/Froyo

rickt1152

Member
Joined
Nov 21, 2009
Messages
137
Reaction score
0
I went from the Rooted stock 2.1 Rom OC'd to 800 to Froyo OC's to 1000. Overall my Droid runs fine with the exception of the stock launcher. When I back out of many applications or hit the home button, it often takes 5 seconds or longer to bring up the icons on my homescreen. I eliminated many of the widgets to see if this helped, but it didn't seem to make any difference. Has anyone else experienced this, and more importantly, any fix. I am going to try some new launchers, but it seems in the past, the replacement launchers typically slowed things down as opposed to speeding it up. I like the five screens, but would gladly go back to three if the speed returned.
 

Kmart95

Member
Joined
Dec 27, 2009
Messages
336
Reaction score
0
Location
North Carolina
Ya i had the same issue so i decided to use launcher pro and it is blazing fast for me on froyo.
 

jroc

Silver Member
Joined
Apr 9, 2010
Messages
3,843
Reaction score
62
Location
Washington DC
^Yea, I recommend the first app u install on Froyo is either ADW Launcher or Launcher Pro. Something other than stock right now.
 
OP
R

rickt1152

Member
Joined
Nov 21, 2009
Messages
137
Reaction score
0
Ya i had the same issue so i decided to use launcher pro and it is blazing fast for me on froyo.

Just loaded up Launcher Pro and it makes a ton of difference. I was ready to go back to 2.1, since I had everything there (except Flash) without the laggy launcher. Thanks for the suggestion.
 

tktouch12

Active Member
Joined
Nov 17, 2009
Messages
1,239
Reaction score
0
I notice it too. I was wondering about this, they will obviosly fix it before release right? Because the 3d launcher is cool, but it is really laggy sometimes
 

Asterisk

Member
Joined
Mar 23, 2010
Messages
280
Reaction score
0
I never really had a problem with the stock one but since I downloaded ADW I can tell that there is a difference. Thanks for the suggestion.
 
OP
R

rickt1152

Member
Joined
Nov 21, 2009
Messages
137
Reaction score
0
Resurecting my own thread with some more details. I installed Launcher Pro which seems to help but upon further use, I am still having significant lag issues under the following circumstances. When I am only away from the home screen briefly, it will come back quickly. However, if I am doing almost anything for more than 10 seconds or so, browsing, email, etc. when I go to exit out and return to home screen it will take sometimes as long as 10 - 15 seconds for the icons to reappear on my home screen. I removed the bigger widgets which made no difference. I have never had this type of lag before and it really makes switching between applications a problem. Any thoughts as to what to try next?
 

Googleaddict

Member
Joined
Dec 3, 2009
Messages
596
Reaction score
0
Location
Denver Colorado
I was ready to go back to 2.1 also, but i tried launcherpro and it works amazingly! Everything is so smooth even with live wallpapers
 

jinx10000

Member
Joined
Dec 10, 2009
Messages
66
Reaction score
0
99% chance it is an app that you have installed.
SetCPU widget used to cause that for me. The stock Froyo launcher is slightly laggy but not nearly as bad as you are experiencing.
Uninstall all of your apps and then reinstall one at a time waiting a little while between each app.
 

tktouch12

Active Member
Joined
Nov 17, 2009
Messages
1,239
Reaction score
0
its interesting that setcpu widget did it, cuz i use that.
but its a lot better with this new froyo leak anyway

. i just removed the setcpu widget and it feels like its running even better now
 

meishkov

Member
Joined
Feb 12, 2010
Messages
956
Reaction score
2
Location
Sterling Heights, MI
I was having this problem with helix launcher2 on SS 3.2, and since I've switched to launcher pro, my phone feels as smooth as it did when I first got it. World of difference.
 

tk0

New Member
Joined
Jun 21, 2010
Messages
9
Reaction score
0
its interesting that setcpu widget did it, cuz i use that.
but its a lot better with this new froyo leak anyway

. i just removed the setcpu widget and it feels like its running even better now

I had major lagging going home after using browser and other programs, and screen slide lag some times lockups for up to 5-10 seconds. i removed the setCPU widget and every thing started running perfect.

im running moto droid chevyno1 ss 2.2 and 1.1g lowv kernel and launcherPro
 

gixxerboy

Member
Joined
Apr 4, 2010
Messages
169
Reaction score
0
Can someone add options to the stock launcher so it is faster like add some of the adw laujncher options
 

AutoLuxLexES

New Member
Joined
Jun 15, 2010
Messages
25
Reaction score
0
I'm having extreme lag as well when returning to home screen.
For those who have extreme lag dL osmonitor.apk. Go to miscellaneous in osmonitor and see how much of /system is being used up. Because mine says 78% is used up even though i transferred like 25 apps To my sdcard. And i even removed livewallpapers, twitter, Facebook, VVMessage, com.Amazon.mp3, and a few other apps

Charley
 

bje1982

Member
Joined
Mar 31, 2010
Messages
534
Reaction score
0
99% chance it is an app that you have installed.
SetCPU widget used to cause that for me. The stock Froyo launcher is slightly laggy but not nearly as bad as you are experiencing.
Uninstall all of your apps and then reinstall one at a time waiting a little while between each app.

I used process of elimination and found that the Set CPU widget was giving me problems like that and when I would go home my scree would be frozen for 10 seconds before I could even swipe left or right. I took the widget away and haven't had the problem since.
 
Last edited:
Top