Keypad disappears during a call

kevinkidder

New Member
Joined
Aug 17, 2011
Messages
4
Reaction score
0
hi!

I have noticed that when I make a call, and need to use the keypad, the screen automatically goes black, not giving me time to use the keypad. I know that the screen lock is a feature to keep me from face dialing, but how does that work exactly? This happens mostly when I am calling voicemail and don't bring the phone to my face.

Any info is appreciated!

Please excuse the autocorrect errors.

Kevin

Sent from my SCH-I510 using DroidForums
 

CTownDroid

Platinum Member
Joined
Mar 6, 2010
Messages
530
Reaction score
382
Location
Cleveland, Oh
Current Phone Model
Nexus 6P
What is your screen timeout set to? If its only 15 or 30 seconds you will have that problem, I changed mine to 1 minute.
 

bweN diorD

Senior Member
Joined
Mar 21, 2011
Messages
1,755
Reaction score
74
Current Phone Model
G2
its not that i dont believe, mine used to do the exact same thing, soon as the call connects the screen goes off.
not sure how i fixed it but it doesnt do that any more
 

Tuna61

New Member
Joined
Jul 9, 2011
Messages
9
Reaction score
0
I am 90% sure the phone uses the light sensor (top right of glass front right next to the ear speaker) to determine whether to turn screen off or not. Just make sure that area is getting plenty of light and it won't be an issue.
I have same issue in a dark room..but not a lot you can do about that. Hopefully they will tweak the sensativity in the next update


sent from Samsung Droid Charge
 
OP
K

kevinkidder

New Member
Joined
Aug 17, 2011
Messages
4
Reaction score
0
Thank you everyone got your replies and help. My screen timeout is set for 2 minutes, so I am pretty sure that isn't the issue. I see the sensor, so perhaps it is a light variation more than just the detection of light? I will try to cover the sensor then uncover it to see if that makes a difference.

I have also seen threads reporting that popping the battery helped, although I don't see how. And success with that?

Kevin

Sent from my SCH-I510 using DroidForums
 

jairzinho

New Member
Joined
Aug 18, 2011
Messages
1
Reaction score
0
I've been having trouble with that, too. It's not related to screen timeout time. It has to do with the proximity sensor. I guess when it's up near your face during a call, you wouldn't want the on-screen buttons to get pressed.

It's really frustrating when you're trying to hit keys during a call, though. The sensor turns off the screen so I can't hit the keys I want to hit.

Anyone know how to modify this possibly?
 

expidia

New Member
Joined
Jul 24, 2011
Messages
18
Reaction score
0
Location
Albany, NY
I've been having trouble with that, too. It's not related to screen timeout time. It has to do with the proximity sensor. I guess when it's up near your face during a call, you wouldn't want the on-screen buttons to get pressed.

It's really frustrating when you're trying to hit keys during a call, though. The sensor turns off the screen so I can't hit the keys I want to hit.

Anyone know how to modify this possibly?

The proximity sensor takes control "after" you press "green call button" or is connected. Once you are connected the screen goes black. This also saves the battery. To use keypad simply pull the phone away from your ear and it lits up so you can type in extension digits etc.

It's confusing because if you are blocking the sensor with your finger, the screen stays black. If you are in a dimly lit car or in the car at night or just turn on the overhead light. Once you get used to how it works, you won't give it a second thought anymore.

If the phone was on your ear how could you type in digits anyway. As soon as you move it away from ear, it lights right back up.
 
Last edited:
OP
K

kevinkidder

New Member
Joined
Aug 17, 2011
Messages
4
Reaction score
0
Thank you expidia! That helps a lot!

Sent from my SCH-I510 using DroidForums
 

Malvado

DF News Team/Mod
Premium Member
Joined
Nov 7, 2009
Messages
1,990
Reaction score
16
Website
www.myspace.com
There's an option in the settings that allow you to choose when to show the dialpad....the options are SERVICE NUMBERS or ALL CALLS.

Sent from my DROID 3 directly to YOU!
 

bweN diorD

Senior Member
Joined
Mar 21, 2011
Messages
1,755
Reaction score
74
Current Phone Model
G2
i have never seen that option, just scanned every menu to confirm.
 

Malvado

DF News Team/Mod
Premium Member
Joined
Nov 7, 2009
Messages
1,990
Reaction score
16
Website
www.myspace.com
I was just in that menu lol...SETTINGS>CALL SETTINGS>SHOW DIALPAD

Sent from my DROID 3 directly to YOU!
 

Malvado

DF News Team/Mod
Premium Member
Joined
Nov 7, 2009
Messages
1,990
Reaction score
16
Website
www.myspace.com
Weird. I would think all android devices have that seeting as it has been on all devices I have owned.

Sent from my DROID 3 directly to YOU!
 

expidia

New Member
Joined
Jul 24, 2011
Messages
18
Reaction score
0
Location
Albany, NY
I was just in that menu lol...SETTINGS>CALL SETTINGS>SHOW DIALPAD

Sent from my DROID 3 directly to YOU!

Ummm, maybe that setting is in the Droid 3 or a rooted Droid Charge, but I don't see it in my stock OS as the other poster has said???
 

bweN diorD

Senior Member
Joined
Mar 21, 2011
Messages
1,755
Reaction score
74
Current Phone Model
G2
root has nothing to do with the menu....
 
Top