Is anyone else having issues with the playstore today?

94lt1

Super Moderator
Staff member
Premium Member
Joined
Jan 16, 2012
Messages
17,041
Reaction score
3,997
Location
SE TX
Current Phone Model
Droid Turbo 2
I can't download anything.. I've already cleared the cache and force closed play services, play store.. Un installed updates... Now it doesn't want to prompt to update... Idk what's going on rebooted the device... Cleared the cache.. Tried to clear the cache through recovery.. That wouldn't work... This is getting annoying...
 
Last edited:
Did a factory data reset... Still nothing..i can't download anything from the play store
 
Last edited:
Grrr..how irritating..anyhow..suggestions and ideas welcomed...I've done a complete FDR. Still no change...
 
I don't have any ideas or suggestions (sorry), but I am able to download from the Play Store. The store is working fine for me.

Sent from my XT1080 using Tapatalk
 
Last edited:
Remove your Google account, reboot, add the account again.
 
Wait... You did an FDR? Well then the Google account was removed. Idk.
 
I'm getting "Error processing purchase" when downloading certain apps.

Sent from my Sony Xperia Z3
 
I even made a second Google account..and tried..same thing..tried it over WiFi with my droid maxx..same thing..so it's definitely a google issue..not on my end..thanx for the input..

On the other side of the coin..the turbo dialer issue I had , is now resolved...:confused:
 
All is well now..it was a google issue..
 
Back
Top