internal storage partitions screwed up

Not open for further replies.


New Member
Sep 2, 2010
Reaction score
So, I've somehow managed to screw up the partitions on my Incredible. It can't mount DATA or CACHE. I saw on this post that it is possible to re-create them, but the user over there mentions using parted. How do I get parted onto my phone? I tried just running it through the shell but it says the command is not found.

Any help would be greatly appreciated.

UPDATE: Fixed it. Thanks goes to -Steveo- and ciwrl over at the Cyanogen forums for helping me figure this out last night.

Here's the solution.

The problem was that I managed to screw up the partitions on my internal storage card, so basically nothing would work properly. I could still get into recovery, though. That's key.

Here's what you'll need:

  1. Working recovery, basic knowledge of adb & the shell
  2. Parted (download here)
  3. stock

Note also that I had run unrevoked forever (so my phone was S-OFF) ... I'm not sure if that's required or not.

So, grab parted from the link above. Now you need to extract the individual binaries from the .zip (the 6 files in the sdparted folder within the zip), ideally to your android-sdk\tools directory. Now push all 6 files (adb push [file] /sbin/). Next, we need to make them useable, so go into the shell (adb shell). Change to your /sbin/ directory, and run: chmod 0755 <file> on each of the 6 files.

Now, we need to fix the partitions. This is assuming that the partitions are there, just the wrong format (which is what happened to me .. I accidentally made them FAT32 instead of ext). So, run the following: parted /dev/block/mmcblk0 mkfs ext2. It will ask if you want to continue, hit yes. When it asks for the partition number, enter 1. Next, when it asks for the format, enter ext2. Let it do its thing. Now, once it's done, run parted again. This time, enter partition 2 (everything else is the same).

Once all that's done, your recovery program should be able to mount both the /data and /cache partitions. If that's true, you're pretty much done! One thing I found was that I couldn't directly install a new OS (I tried both Cyanogen and Ultimate). In both cases, it would look for stuff in the davik-cache that it couldn't find, so something wasn't installing correctly I think. So, if that happens, flash back to the stock (put it in the root of your /sdcard/ and let hboot install it), and then root your phone anew. That's what I ended up doing.

Again, huge credit for this goes to -Steveo- and ciwrl for helping me figure out which partitions were the right ones (and for supplying parted, which I hadn't been able to find anywhere). If something doesn't end up working, just drop me a pm and we'll see what we can do.
Being the idiot I am, I am attempting to redo the partitions on my phone as well... Everything goes well until I change to the /sbin/ directory, I am getting an error stating /sbin/sh: /sbin/ permission denied. Please Help thanks
Being the idiot I am, I am attempting to redo the partitions on my phone as well... Everything goes well until I change to the /sbin/ directory, I am getting an error stating /sbin/sh: /sbin/ permission denied. Please Help thanks

Did you chmod the files? sh means you're trying to run something.
I tried, but got that permission denied error each time. MY phone will boot now, I flashed the stock PB31IMG and its up and running with the stock verizon rom. I haven't tried reflashing clockwork, and loading a rom yet, as I need my phone for the weekend. I now can access the internal storage from my pc, is there a way I can format it from there?
help me please

I did the same thing with my internal memory, but I have no idea how to do anything you said, i downloaded sdk and jre and jdk and parted and all that and I can't figure out how to get any of it to run and i really just need help.
I used the same guide and it saved my phone. This has happened to quite a few people evidently.

Sent from my ADR6300 using DroidForums App
Htc eris

Hi guys I have the same issue well kind of similar i wrote wrong nv items for following some guy method of rooting and now the eris turns on for like 3 seconds and off again non stop. I read the solution above is this solution the same for ERIS? I would greatly appreciate it if someone can help me with this fustration. I also have been looking for the stock rom but no luck... I beg you please help me with this issue.

Thank you so much in advance.

Are you looking for the stock ROM for the Incredible or the Eris?

thank you so much for the fast response it was late this morning when i found the thread with the same issue I have. I change the nv items that belong to the motorola droid into the htc eris and this issue happened. this was a long time ago when i started tampering with cell phones. I am looking for HTC ERIS STOCK rom. I would really appreciate if you can point me in the right direction. I am learning how to work with adb shell but dont really understand it. again thank you enlightned for your assistance....
i need help with missing partitions but phone wont power on
Not open for further replies.