How to sync coporate calendar to gmail account!


New Member
Nov 18, 2009
Reaction score
First of all, hello to everyone. I'm new to the forum and I've had my droid about 10 days now. This phone is truly a dream come true for me. I came from an iPhone due to AT&T's horrible network service, 3G coverage, and overall apathetic attitude towards that issue.

Ok so here goes:

I searched the net and have yet to find a solution for this problem, which may not be common, but it is one that I needed to address. Maybe this can help someone else out there as well.

I have two gmail accounts, one for personal and one for business. I do need to share the business calendar app and email with two other people that work for my business. We are a small company and really do not need to spend the extra dollars on Exchange hosting, so I wanted my business account on the "Coporate Calendar" app of my droid and my personal account on the regular Calendar app. Here is how I did it:

Set up personal account in the "gmail" app and sync everything. This will take care of the personal calendar, if you use Google calendars.

Next set up the "Coporate" account. I got this idea from the way that I used to set up my iPhone for gmail push and sync.

1)Go to the Coporate Calendar app.

2)fill out gmail address and password.

3)On the next screen you will need to make some changes.

a)Domain\Username should look like this ------ [email protected]
c)Exchange Server needs to be changed to this -----
d)Leave"Use Secure connection" checked. (I also checked Accept all SSL certificates.)

4)Click next and choose your options.

5)Click next and name your account.

6)Your done! Now you have succesfully set up a separate calendar for a seperate gmail account for whatever your needs may be. It will sync and works great.

P.S. ----- The email for the setup does not seem to be delivering messages without exra setup. Go in the "Email" app, and choose accounts. From here choose to add an account and just put in [email protected] and your password. This does not have the ability to push for some reason, but you can set it to check every 5 minutes.
NOTE: You will see two email addresses in your combined inbox with the same name. One of them is set up on Exchange from the Corp Calendar and will not retrieve messages. Please let me know if anyone finds a fix for this issue.

Alternatively, if you would like to have push on the "business" gmail account, you can just set it up in the "gmail" app as a second account instead. This will give you push on that account.

I hope that this helps someone. I worked for me!
Last edited: