Gmail not pushing anymore

Dec 1, 2009
Reaction score
My Gmail account won't automatically notify me or update my inbox anymore, this just randomly just started happening within the past few days. If I hit the refresh button while Gmail is open, my inbox will refresh properly but I don't know why it's not doing it on it's own anymore. I checked on the sync page and Gmail is still checked like always.

Anybody have any ideas of what I need to do to fix this?
When you say gmail is checked do you mean the account or the actual check mark once you select the account?
Restart your phone. I have had the same problems lately and this seems to be the fix for me.
Restart your phone. I have had the same problems lately and this seems to be the fix for me.

+1 on this...I noticed this happening a week ago. I checked my account settings and noticed that Syncing for this account was turned off...and I didn't turn it off. I rechecked the box and rebooted (hold the power button until you're prompted to power down your phone). I have been using this trick whenever I install new apps too. I noticed that after installing several apps in a short period of time the Droid got a bit sluggish. After the reboot everything worked great!
Soft reset seemed to work! 99% of the time that is the fix to my problems but I just always think way farther into it. Thanks guys!
I just got a replacement Droid 2 Global and this has been happening since I got the phone this tuesday. I did a reboot yesterday and it seemed to be syncing automatically again and in the last hour I noticed I was getting emails to my inbox on my computer but not my phone.

I guess the first solution is Reboot but that seems like a roundabout fix to an issue that shouldn't be an issue with this phone. Why all the sync issues with Gmail to a GOOGLE phone?
Better fix than reboot?

My gmail had been sync'ing fine automatically, then suddenly stopped. I would only get emails if I manually refreshed. Meanwhile, all my other non-gmail accounts continued sync'ing fine. After poring over my settings (which I still believe were all correct), deleting my gmail app storage, and all the other suggestions... I happened across the suggestion about using the Power widget, and tried it, and it worked! In short, add the Power widget. If the sync icon is off, turn it on. If it's on, toggle it off, and back on again. This fixed it. I have no idea what was not set correctly, but it was nothing I could find through the settings provided. I hope this helps.
I did the power widget thing and today the pushing has been worse than usual. Even rebooted the phone. and still there is either a great delay (10 minutes) between the emails coming in or no refresh at all unless i manually activate the sync with the power widget (toggling it back on and off).
sigh, i don't understand why there is such an issue with google mail on a GOOGLE PHONE
Mine hasn't been working for a few days either. Only an automated refresh will pull new mail in.
Are you mostly using the cell network or wi-fi? Since I found and did the Power Widget solution, my gmail has been fine - not sure what wedged it nor what was set wrong. If you go into Wireless/Networks, Manage Networks, then menu to Advanced, what is your wi-fi sleep set to? If relying on wi-fi much, you might want to set to Never (sleep) so it won't switch back and forth... in case that's a factor..._