Gmail Inbox on Droid different from Inbox on web

number6

New Member
Joined
Dec 29, 2009
Messages
28
Reaction score
0
Not sure if I'm missing something or if this is really a problem. I did a quick search of the forums, but couldn't find anything relating to my particular situation.

I have a Motorola Droid syncing with a Gmail account. Incoming mail syncs just fine (in fact, I just got the "Welcome to DroidForums" message on my Droid with no problems). I've also confirmed that the Gmail account/sync settings are correct.

Yesterday, I moved/archived/deleted several messages from the Inbox using the Gmail web interface on my laptop, but these messages are still showing up in the Inbox when viewed from my Droid. I've done a manual Refresh a number of times since yesterday, and am getting new mail, but the moved/archived/deleted messages persist on my Droid. I deleted several messages from my Droid, and they all disappeared from the web interface Inbox. But not the other way around.

Am I missing something? Is there a problem with changes made through the Gmail web interface showing up on the Droid Gmail Inbox?


-----
Be Seeing You.
 

JayMonster

Member
Joined
Dec 1, 2009
Messages
775
Reaction score
1
This is very bizarre. I have seen a message linger behind... both ways, but a refresh has always cleared up the issue.
 
OP
N

number6

New Member
Joined
Dec 29, 2009
Messages
28
Reaction score
0
Hmm. To add to the strangeness, rebooting the phone seemed to do the trick. My Droid Gmail Inbox now matches my Gmail web interface Inbox. But previously, no amount of manual Refreshes would do anything but retrieve new mail.

Android's not taking after Windows, is it? A reboot fixes everything?
 

Berzerker

Member
Joined
Dec 22, 2009
Messages
331
Reaction score
0
It seems like it.

I believe also that Gmail will only push changes with new mail. So in order for that to update without a reboot, you need to receive a new email.
 

hookbill

Premium Member
Premium Member
Joined
Nov 30, 2009
Messages
19,374
Reaction score
8
Location
N.E. Ohio
To fix this issue you will need to unsync gmail on your phone, then set your email to check every 5 minutes. To remove sync go to settings/accounts & sync then tap your Google sync. Find your gmail and remove sync. Then go to settings on your email (not gmail) and set it to check every 5 minutes.

Hope this helps.
 
Top