G-Mail contacts

QMaverick

Member
Joined
May 11, 2010
Messages
55
Reaction score
0
For some reason I can not get the contacts in my phone to do a 2-way sync with g-mail. Instead, when I put a contact in my phone and save it, it doesn't go to my gmail, and when it doesn't go to my gmail, it gets deleted from my phone the next time it updates.

It's kinda frustrating that, every time I forget that I have to add a contact in through G-mail, the contact I enter into my phone disappears. Is anyone else having this issue?
 

hookbill

Premium Member
Premium Member
Joined
Nov 30, 2009
Messages
19,374
Reaction score
8
Location
N.E. Ohio
I believe you of course, but it doesn't make sense. If it's going to sync it should sync both ways.

I know on the new Droids it's a bit tricky to add a new contact but the old Droid was just add contact and it always sync to my gmail.

Usually when I hear of something this unusual the only thing that will fix it may be a factory data reset. Unless your missing something in your settings. Have you double checked the settings on the Droid?
 
OP
Q

QMaverick

Member
Joined
May 11, 2010
Messages
55
Reaction score
0
I've checked the settings in the phone--they seem to be correct (set to sync). Is there a setting in Gmail I'm missing somewhere or something? It's odd . . .
 

dlwhtrose

Super Moderator
Premium Member
Rescue Squad
Joined
Dec 10, 2009
Messages
2,811
Reaction score
31
Location
God forsaken desert, wishing to be back in Dixie
which Droid do you have? I would suggest going into settings > accounts & sync > click on your gmail account. There you should see three choices: Sync Contacts; Sync Gmail; Sync Calendar Make sure the box next to each is checked. Then hit the menu key and say "sync now" Hopefully this fixes the situation
 
OP
Q

QMaverick

Member
Joined
May 11, 2010
Messages
55
Reaction score
0
which Droid do you have? I would suggest going into settings > accounts & sync > click on your gmail account. There you should see three choices: Sync Contacts; Sync Gmail; Sync Calendar Make sure the box next to each is checked. Then hit the menu key and say "sync now" Hopefully this fixes the situation

It's a rooted Droid running FRG22D (Froyo 2.2).

That's how my sync settings look...weird.
 

spacemonkey

New Member
Joined
Oct 12, 2010
Messages
5
Reaction score
0
Location
Bay Area
I am having a simular issue. My contacts are not syncing up with G-mail, even though i have them set to sync. Have you found out what the issue is that you are having?
 
OP
Q

QMaverick

Member
Joined
May 11, 2010
Messages
55
Reaction score
0
I am having a simular issue. My contacts are not syncing up with G-mail, even though i have them set to sync. Have you found out what the issue is that you are having?

I haven't figured anything out--though I did put a contact into my phone the other day and had it successfully sync. It seems to be a hit-and-miss issue.
 

dlwhtrose

Super Moderator
Premium Member
Rescue Squad
Joined
Dec 10, 2009
Messages
2,811
Reaction score
31
Location
God forsaken desert, wishing to be back in Dixie
spacemonkey :welcome:to the forums. I see that you have an Incredible so I am not sure my advise to QMaverick will work for you since he is on a Moto Droid.

Have either of you double checked to see if all your google accounts have been selected to sync? To do this go into settings > accounts & sync > click on your gmail account. There you should see three choices: Sync Contacts; Sync Gmail; Sync Calendar Make sure the box next to each is checked. Then hit the menu key and say "sync now" Hopefully this fixes the situation

If not (and especially for the Incredible) let me know and I can see if anyone else has had this happen to them.
 
OP
Q

QMaverick

Member
Joined
May 11, 2010
Messages
55
Reaction score
0
I've checked the settings in the phone--they seem to be correct (set to sync). Is there a setting in Gmail I'm missing somewhere or something? It's odd . . .

I should've been clearer here: yes, all of my accounts are set to sync, and it does work SOMETIMES. Other times, however, it does not. I remember when I first got my phone and had my contacts transferred from my Storm to my Droid, they all disappeared after the first sync instead of being put into my Gmail contacts.

Oh, while I'm at it, is there a way to turn off the merge-contacts feature? For instance, my wife's name is Amanda, and my sister-in-law's name is Mandy. The phone puts those together into a single contact which I then have to separate if I reinstall my OS to some other new rooted version. It's a minor nuisance, but a little annoying.

Also, thanks for looking into things! :)
 

dlwhtrose

Super Moderator
Premium Member
Rescue Squad
Joined
Dec 10, 2009
Messages
2,811
Reaction score
31
Location
God forsaken desert, wishing to be back in Dixie
Well QMaverick you have me on this one. I have never heard of merging contacts before. I have seen them duplicate because of Facebook or other similar apps. I am going to link this thread to the rest of the Rescue Squad to see if anyone has any ideas.
 

DF Smod

Silver Member
Joined
Apr 23, 2010
Messages
11,341
Reaction score
93
Let me give this a shot

If you have two different contact icons for the same person ie: facebook and google contact, you can go to that contact select edit contact, press the soft settings key and select "join" it will then prompt you on what contact to merge it with, after a contact has been merged if you follow the same steps above you will also have a "seperate" option in the "edit contact settings menu"

This is as much I know about combining/merging/seperating contacts...I hope it helps :)
 
OP
Q

QMaverick

Member
Joined
May 11, 2010
Messages
55
Reaction score
0
Let me give this a shot

If you have two different contact icons for the same person ie: facebook and google contact, you can go to that contact select edit contact, press the soft settings key and select "join" it will then prompt you on what contact to merge it with, after a contact has been merged if you follow the same steps above you will also have a "seperate" option in the "edit contact settings menu"

This is as much I know about combining/merging/seperating contacts...I hope it helps :)

Yup, that's how I currently separate them--thing is that some of them do it automatically, which is annoying. :)

Thanks for putting the word out there guys. Right now, I typically log on to the web version of GMail to add a contact just to be sure it doesn't disappear from my phone, which is tedious.
 

Tallica

Premium Member
Premium Member
Rescue Squad
Joined
Mar 17, 2010
Messages
3,259
Reaction score
1
Location
Middleboro, MA
Merging automatically I've never heard of, maybe the names are too close (Amanda, Mandy), droid must think it's just a nickname.

Try adding cell or home after one of the names and see if it still does it.

As far as the sync issue, that one is strange too. Don't know why it will only sync one way.

Will try to look into this more....
 

Tallica

Premium Member
Premium Member
Rescue Squad
Joined
Mar 17, 2010
Messages
3,259
Reaction score
1
Location
Middleboro, MA
K, might have found a fix, try this and let us know if it worked, this is from the gmail help forum:

Yay, problem solved - here's what I did:
1. Exported all GMail contacts to desktop as csv. (10 seconds)
2. I deleted all contacts (approx 1500) from Gmail, using the older version for the "select all" feature, which is missing in the newest version.(1 minute)
3. I waited for the phone to Auto-Sync with Gmail. Within a few minutes the Phone's address book was absolutely empty, like the Gmail. (3 minutes)
4. I imported the csv file into the Gmail. Within a few more minutes All the contacts Auto-Synced with the phone. (15 minutes).
5. The only inconvenience is that if you had assigned images to your contacts for the caller ID, you will have to do it again... The sync with Facebook worked automatically.

Now I can edit all contacts from Gmail and from the EVO 4G.

I think the glitch was somewhere with the date(s), as all problems were with the contacts created before the 2.2 update.
 
Top