Droid only reading half of my MP3 IDE tags


New Member
Mar 4, 2010
Reaction score
Hey there, I was hoping I could get some help with this issue. I've searched all around, and I can't seem to find anyone that has the same problem...at least someone that hasn't been able to fix it.

My music uploaded great the first time, but I was noticing that some of my songs, and it seems to be about half of them, aren't reading the info correctly. The track title is whatever the file's name is; then the album and artist are unknown.

In my computer, both iTunes and WMP read the tracks fine. So I did a search, and somebody solved the problem by allowing WMP to sync all the music itself. That was a pain in itself, trying to keep the same settings that iTunes was using...but I eventually got the playlists and the settings I wanted. Synced it, and still having the same issue. They're all MP3, and all their info checks out on the IDE tags, the Droid just doesn't seem to want to read specific ones. Anyone know of a fix for this?
Ru using a program to transfer ur music? i just got my droid 2 days ago and im pumped its awesome.....however i have not had time to try to get music on it till now. so if u did use a program what is it? sorry im not much of help but im wondering the same.
I wasn't running a specific program at first, just using File Explorer in Windows, then I used Windows Media Player to transfer after. Both had the same issue.

Also, some of them had art attatched, and some didn't. It's not a pattern, because some of the ones with art stayed, and some didn't.
I am having a similar issue on my Droid. I have a few mp3s on my SD card and randomly today I noticed that my artist and album fields are missing from my songs. If I go to view songs, I see my tracks still there, but the artist and album info doesn't seem to be there anymore. The odd thing is that I haven't added new songs recently so it seems a little random. Possibly a glitch/bug in the music player or OS? I also tried rebooting the phone, unmounting the card, rebooting. No dice.
Hey. Sorry for bumping such an old thread, but this is the only thing I came across on google that had any reference to this error. I'm having the exact same thing happen, it doesn't read the tags for half my files (it stops at about O alphabetically, there's no pattern beyond that). Did you ever figure out a fix for it?