Connection Error sendng mail


New Member
Nov 20, 2009
Reaction score
Driod is a great phone, but I'm having one major problem -- Unable to send e-mail. I've entered appropriate settings for my email host ( Incoming mail works fine, but when I try to send mail, I get a "Connection Error" message. I've tried all combinations of server addresses and port numbers suggested by e-mail host, to no avail. I called Verizon support. They tried and failed, then suggested that as a work-around I use a yahoo mail server for sending. They walked me through the required settings, and when I tried to send I again got a "Connection Error" message. Verizon then contacted Motorola, and reported to me that the problem is "under investigation". They promised to get back to me, but so far that has not happened. Can anyone help? Sounds to me like there's a fundamental problem here. Thanks.
I'm having email connection problems (Yahoo! mail) only when the phone is on WiFi. On 3G, mail works fine. Can you switch between WiFi & 3G to check if email's working?
I haven't used WiFi, and indeed based on a comment that I saw somewhere similar to yours, I tried disabling WiFi, but that didn't help.
Problem solved! Verizon transferred me to Motorola tech support. They told me to delete the e-mail account, power off the phone, remove the battery for several seconds, then set up the e-mail account again. That did it, and outgoing e-mail now works (at least to the extent of a single test message). It's a shame that I killed several hours on this (and Verizon itself did not offer the successful suggestion). But hopefully all's well that ends well will apply.
Michael, I am glad it worked for you, but I still have the same problem after deleting the email account, removing the battery, restarting, and reentering the email account settings. I should have taken this email problem more seriously before my 30-day period was up.

If anyone has another idea, I will try it.
Sorry you're having problems. I know how frustrating it is. I suggest that you contact VZW tech support, let them try to fix it (though they were not at all insightful in my case), fail, and then put you through to Motorola. To my surprise, VZW and Motorola were very diligent about returning calls and working on the problem -- my sense was that mine was not the only complaint on the subject and they wanted to get to the bottom of it.

Forgive me if I'm suggesting the obvious, but I assume that you've double checked server URL's, proper port Nos, security settings, etc. One easy test that I did was to intentionally force the URL to be wrong (by just inserting an extra character in the URL) to be sure that the error message changed to server not found (to assure that I was actually reaching the server in the first place). Good luck.