CM7 RC2 on D1 Wireless Stopped Working

mascasa

New Member
Joined
Jan 6, 2011
Messages
2
Reaction score
0
Rom was working pretty well for 4 days until last night. The wireless stopped working. It says my networks are out of range, and I cannot search for new wireless networks. It used to work just fine. Wireless Tether still works, so I know the hardware is good. I am running CM7 RC2 on a D1 with SetCPU.

Any ideas?

Thanks in advance!
 

swallisa

Member
Joined
Aug 18, 2010
Messages
212
Reaction score
0
Location
SoCal
Try a different kernel one of chevy's GB kernels should do the trick.
 

icomrade

New Member
Joined
Oct 4, 2010
Messages
11
Reaction score
0
Don't update busybox, I can't obtain an IP from any network with Busybox 1.18.3 and only some work with 1.17.1. Try reflashing the rom without wiping cache or data, that should fix it.

Sent from my Droid using DroidForums App
 

mightybrick

Active Member
Joined
Nov 14, 2009
Messages
272
Reaction score
6
Location
So. Utah
Rom was working pretty well for 4 days until last night. The wireless stopped working. It says my networks are out of range, and I cannot search for new wireless networks. It used to work just fine. Wireless Tether still works, so I know the hardware is good. I am running CM7 RC2 on a D1 with SetCPU.

Any ideas?

Thanks in advance!

Next time this happens, just forget all the remembered networks and then wifi will scan and connect properly again.
 

PetRiLJoe

Member
Joined
Mar 28, 2010
Messages
278
Reaction score
1
Location
Opelika, AL
First off in my situation I'm referring to Wi-Fi only, not just wireless in general, because that was the only thing that affected my phone.

This has happened to me before when I tried out a new kernal. I could not scan for new networks and checking the checkbox to turn on WiFi would result in no change from the word "DISCONNECTED" so I would have said it's a kernal thing in my case. I have not had it happen seemingly randomly as the original poster.

I have reflashed my older kernal to get WiFi working.

Next time this happens, just forget all the remembered networks and then wifi will scan and connect properly again.
@ mightybrick , thanks for the tip, I will have to try that next time it happens to me.
 
Top