Battery draining fast on airplane mode

CrimsonTide55

Member
Joined
Jun 25, 2011
Messages
129
Reaction score
3
Location
Bama
At night I put my phone on airplane mode to conserve battery and I went from 92% to 45% last night. I did this with my droid x and would only loose like 2% or 3% overnight. Is there a setting I'm missing or does this phone just not have good standby time. I guess I could just turn off the phone but I would rather not. Battery life otherwise is good..

Sent from my Galaxy Nexus using DroidForums
 
OP
CrimsonTide55

CrimsonTide55

Member
Joined
Jun 25, 2011
Messages
129
Reaction score
3
Location
Bama
yea Android OS was using the most %. It just doesn't seem like my battery drains that fast while I'm using it. Hope the update helps otherwise I may just turn off my phone at night. Thanks for the reply

Sent from my Galaxy Nexus using DroidForums
 

mountainbikermark

Super Moderator
Staff member
Premium Member
Joined
Sep 5, 2010
Messages
7,421
Reaction score
3,867
You can narrow it down to what is doing it with Watch Dog and if it's an app causing cpu to keep running you can kill it. It might be trying to do a late night sync, like backup assistant or something

Support Our Troops!!!
<><
Sent from a Rezound phone via Blue TapaTalk
 
OP
CrimsonTide55

CrimsonTide55

Member
Joined
Jun 25, 2011
Messages
129
Reaction score
3
Location
Bama
Alright I'll try using that and see if something shows up. Thanks for the suggestion

Sent from my Galaxy Nexus using DroidForums
 

BayouFlyFisher

Rescue Squad
Rescue Squad
Joined
Dec 10, 2009
Messages
4,950
Reaction score
17
Location
Baton Rouge, LA
Some phones, mine included, have a "Keep Awake" bug. It seems that if you use the power button to put your phone to sleep, it doesn't really put the phone to sleep. If you let the phone time out via the automatic display timer setting the phone will actually go into sleep mode. You can verify this by comparing your "Keep Awake" time to your total battery time. When I was experiencing this bug my Keep Awake time would 50-60% of the total time even when the phone was dark and in my pocket. I'm using a custom rom now that fixes this issue and my Keep Awake time, while not being used, will be a few minutes per hour.

Good luck.
 

BayouFlyFisher

Rescue Squad
Rescue Squad
Joined
Dec 10, 2009
Messages
4,950
Reaction score
17
Location
Baton Rouge, LA
I forgot to add that one of the Devs (don't remember who right now) says this issue is actually caused by one of the Google apps that is started automatically initializes the camera and that some sensor is then left running and that results in the high Keep Awake times. He said you could test it by opening the camera app and closing it. He said that would turn off the sensor. Sorry I can't remember the exact details, but I'm sure you can find them on XDA.

Good luck.
 

prowler85

Member
Joined
Mar 2, 2010
Messages
497
Reaction score
8
Location
Arizona
Some phones, mine included, have a "Keep Awake" bug. It seems that if you use the power button to put your phone to sleep, it doesn't really put the phone to sleep. If you let the phone time out via the automatic display timer setting the phone will actually go into sleep mode. You can verify this by comparing your "Keep Awake" time to your total battery time. When I was experiencing this bug my Keep Awake time would 50-60% of the total time even when the phone was dark and in my pocket. I'm using a custom rom now that fixes this issue and my Keep Awake time, while not being used, will be a few minutes per hour.

Good luck.

Thanks for this. I checked and mine had a keep awake time of 2 hours with a total battery time of 4 hr 20 min, so nearly 50%. Screen on time was at about an hour, and battery down to 42%, so this was causing my battery drain. And I almost ALWAYS turn my screen off manually (vs. letting the screen saver time-out) to save that extra 30 seconds of screen on time.

I have Axiom 2.3 running and apparently this isn't fixed in this ROM yet, so I guess I'll let it timeout until I change ROMS.

And I'd venture to guess this is what is going on with the OP. Recently went skiing for two days and put my phone in airplane mode while skiing, since I knew it would be searching for service the whole time. First day it was at over 80% at the end of the day (dropped at about 2% per hour max), but second day it was down to 20%. So based on what you said I'd guess the first day the screen timed-out mostly and the second day I mostly turned the screen off myself.

May have to try another ROM to see if I can get this fixed.
 

BayouFlyFisher

Rescue Squad
Rescue Squad
Joined
Dec 10, 2009
Messages
4,950
Reaction score
17
Location
Baton Rouge, LA
Thanks for this. I checked and mine had a keep awake time of 2 hours with a total battery time of 4 hr 20 min, so nearly 50%. Screen on time was at about an hour, and battery down to 42%, so this was causing my battery drain. And I almost ALWAYS turn my screen off manually (vs. letting the screen saver time-out) to save that extra 30 seconds of screen on time.

I have Axiom 2.3 running and apparently this isn't fixed in this ROM yet, so I guess I'll let it timeout until I change ROMS.

And I'd venture to guess this is what is going on with the OP. Recently went skiing for two days and put my phone in airplane mode while skiing, since I knew it would be searching for service the whole time. First day it was at over 80% at the end of the day (dropped at about 2% per hour max), but second day it was down to 20%. So based on what you said I'd guess the first day the screen timed-out mostly and the second day I mostly turned the screen off myself.

May have to try another ROM to see if I can get this fixed.

I experienced a strange issue initially with 2.3 also. When I first loaded it I noticed that my Keep Awake time was very, very high. I assumed DroidTh3ory had dropped that feature. But then I read that he had not. I went back to CWR and reflashed the rom without wipes and it is now working. YMMV!

Good luck.
 

prowler85

Member
Joined
Mar 2, 2010
Messages
497
Reaction score
8
Location
Arizona
I experienced a strange issue initially with 2.3 also. When I first loaded it I noticed that my Keep Awake time was very, very high. I assumed DroidTh3ory had dropped that feature. But then I read that he had not. I went back to CWR and reflashed the rom without wipes and it is now working. YMMV!

Good luck.

Well thanks again then! I'll give that a try and see if it fixes the problem.
 

Liam1027

New Member
Joined
Jan 21, 2012
Messages
1
Reaction score
0
I'm having the same problem but it's a pretty new issue. I've been running cm7.1 for a while now and use tasker to put my phone in airplane mode overnight as well as when I put the phone face down. This was working perfectly until I flashed incredikernel.

With incredikernel, the battery is terrific outside of airplane mode, but once I enable airplane mode the battery drains fast. Spare parts says its android system. Something must be keeping the kernel awake. I might buy betterbatterystats to investigate further.

There are also some good tips in this thread that I'll try too.
 

alboboy10

Senior Member
Joined
Jan 8, 2010
Messages
1,808
Reaction score
19
My phone went from 65 to 32 during the night on wifi. Eight hours of sleep or so.

That's crazy.
 
OP
CrimsonTide55

CrimsonTide55

Member
Joined
Jun 25, 2011
Messages
129
Reaction score
3
Location
Bama
Try force closing the camera if its running. I read somewhere that there is a sensor in the camera that will keep the camera constantly running if its left running in the background. I always do this and have disabled Google+ and Google talk and now I only loose like 4 or 5% overnight on wifi

Sent from my Galaxy Nexus using DroidForums
 
Top