Applications Not Installing


Jul 4, 2010
Reaction score
Hey Guys,

I am having trouble installing applications. I first realized it when I tried to install updates from the market. They download successfully but then I get that yield sign-looking error (yellow triangle with exclamation point) and it says Installation Unsuccessful. After that, I noticed it's not just updates. I tried downloading an APK myself and installing it from a file manager, but I get the same Installation Unsuccessful. My terminal emulartor was giving me problems (I was using Better Terminal Emulator Pro) so I uninstalled it to try and reinstall it, but now I can't do that. So now I can't do anything from the terminal like run commands to fix it.

I am running Android 2.2 Froyo on ChevyNo1's Simply Stunning 4.3 Source-Built ROM. I know it has the App2Sd feature included and there is a script that can set it to on (all apps go to SD), off (all apps go to phone), or auto (not quite sure how this setting determines where apps go ). Also, I manually moved all of my apps to the SD card that restored themselves back to phone after I switched to the ROM. These were the apps I had installed before I was using the ROM.

Any ideas on how to fix this? Should I reinstall the ROM or flash back to a previous state with nandroid and try again or what?

Thanks in advance for the help!

I am having the same issue. I thought it was the market at first but I went directly to the downloads dire and found all the download.*.apk files and tried installing one of those via Root Explorer and I just get the installing ......... and they never install.

Is there possibly a permissions issue I am missing. I have tried fixperm to see if that would help.

Also I can not even UNINSTALL any app on the phone either as it just sits on the uninstalling screen.

So If anyone has any suggestions .. I have formatted data and cache and started from scratch with the bb 0.4 stock and the deodexed. and have tried different kernels from Chevy. But can not seem to fix this issue.

Please help me search to determine if I am just missing some little item for installs to work correctly?

Update: I tured off the App2SD feature which installs everything to the SD card, then I went to an app that I had an update for (Handcent SMS) and moved it to the phone, tried in stalling the update, and it worked, so I now know that is a problem with App2SD. I'll post in the ChevyNo1 SS 4.3 forums to in order to find out how to fix this in this ROM.

How do you turn off apps2sd.. I know it is either (a) auto (e) external or (i) internal. Just change it to internal?

EDIT... I think I might know the problem then. My SDCARD was formatted with the phone so I am wondering.... I have been "moving apps to the SDCARD" and maybe that has screwed up the entire flow and now I can not install or uninstall. So maybe all I need to do is back up everything on the sdcard and then reformat it so it has the fat32, ext2, and linux-swap partitions and then reload the SDCARD with the information and redo the rom.

Hopefully this is truly the issue .. and it may solve it. since we went from a rom that only installed internally to a rom that supports install to SDCARD.
Last edited:
For the ROM that I'm using, the creator included a command 'a2sd [on/off/auto]' that lets you control it. I just ran 'a2sd off' and it did the trick, which enables all future apps to be installed into phone storage. Not sure how to do it in general.
What I stated above Worked perfectly.. I searched regarding partitioning my SDCARD to work with apps2sd and I took it out of my phone. I resized it so that it had 3 partitions 1 fat32 followed by an ext4 and then by a Linux-swap. I put it back into the phone and booted up and low and behold it is working perfectly. My phone is running lean , fast and mean. I love this phone. Hope this helps others. I now also can set apps2sd to push them to the SDCARD.
Hey Hasher, thanks for the tip, glad to hear you got yours working. Could you please link me to the resources you used to learn about formatting the SD card to work with Apps2SD? I will Google this when I get a chance but I anticipate it being a tricky search, lol. I really appreciate the help.

Oh, and I know that Chevy included a bunch of different filesystems as "modules" in his ROM, but I don't know exactly what that means or how that works, but he was also listed the file system files separately on his site.
Googled it.

I pretty much just read all the items i found by googling it.

The easiest was using a partition manager program on my laptop to resize the fat32 down and then creating a Linux-ext2 and Linux-swap partitions that were after the fat32 in that order.

that way I did not lose any data on the fat32 partition and had the other 2 added easily.

I did this by taking the microsd out of the phone and reading it from my laptop slot where I inserted it.
Nice, sounds easy enough. Thanks for the info Hasher. I'm gonna installl some new ROMs and test it after that. If it still doesn't work, then I'll proceed with trying to format the SD card.