anyone having problems with rm/cw and sprecovery follow this


Regular Member
Rescue Squad
Dec 23, 2009
Reaction score
install a terminal emulator (I prefer j android hacker but its up to you) and the install sprecovery 99.3b. Use the terminal emulator to flash sprecovery image

Push sprecovery using terminal emulator, if that do not work then use rsdlite.

here is the file: MEGAUPLOAD - The leading online storage and file delivery service

place sprecovery file on the root of your sdcard DO NOT RENAME

here are the directions:
19. Open Terminal Emulator and type DO NOT TYPE THE QUOTATION MARKS!
"su" press enter and allow
"flash_image recovery /sdcard/recovery-0.99.3b.img"
"reboot recovery"
Last edited:
also, Rom Manager 2.0 was just released today with a lot of error checking in place. mainly checking for issues with stuff before attempting to install. check it out. should be a great update. problems now need to be reported to devs so that they fix their install zips. I know one issue was spaces in filenames.

also, for recovery, there's been an option in RM for a few revs not to erase recovery before flashing a new version. this is helpful! look for it in settings.
those having an issue with getting into sprecovery or in any recovery. I simulated the failure.
If you can not get into recovery you can follow the op, but if you just want to get into cw recovery then download the clockwork recovery file and follow the same steps but just substitute SP with CW.
Great help, been having this issue for a week now. I finally just loaded an update to my phone and used sprecovery. Maybe I'll be able to fix Clockwork now, although I imagine that it will get patched before I need to use it again.
I keep getting a re-read error and write error when i run that command, on every line. It says out of memory. I have 40meg free on my phone and gigs open on my sdcard so i do not know what the problem is. I have tried doing the flash between sp and cm over and over and that does not help either. Any ideas what i can do? I really want to either install a faster kernel or restore a backup that CM worked properly.
ok i need sopme help pleese i was using droid root helper and on the second group 2nd one down i pushed to do an install now stuck on the word droid half on and freezes now cant get into recovery with power x just keeps going back to motorola emblem HEEELLPPP pleese email is kaije32@hotmail if any one has a fix thank you any and all i love this site and learned a lot here ,sorry not such a great typer
I have tried this a number of times. Downloaded the extracted file to my sdcard root. Gone to terminal emulator. Typed in "su" with no quotes. Typed in "flash_image /sdcard/recovery-0.99.3b.img" and I keep getting flash_image: not found. Any idea why?

I can't get this to work. I am downloading and extracting the file, and putting it on my sdcard root. Afterwards I type in terminal emulator:

flash_image /scard/recovery-0.99.3b.img

Everytime I get flash_image: not found

What's up with that? Thanks.
If you are wanting to stay with RM and CW then here are a couple of steps to follow that should help you when using ROM Manager and ClockworkMod

First, always clear the download cache in ROM Manager. To do this go into RM > menu > clear download cache. It is a good practice to do this before you download anything in RM.

Second, if available, always use WiFi when flashing/downloading anything in RM. RM seems to like WiFi better than 3G. RM seems to download faster and cleaner when using WiFi.

Third, if you are still experiencing troubles with RM, make sure you have BOTH the paid and free versions of RM. To check go to your market > menu > downloads. Once the list populates look for both RM free and RM premium.

Lastly, you can try to fix permissions in RM. This sometimes fixes the unusual force closes and such. I usually do this as a very last resort.

Hope this helps you out if you are wanting to use RM/CW.