Accessing .xml file of game and changing values has no effect


New Member
Oct 4, 2013
Reaction score
Hey guys,

Dunno if any of you are encountering this, but I have trouble with when changing the .xml values of a game, say max money and setting it to 999999. I save the .xml file and when I start the game, nothing has happened. What's worse is that all my data is gone and I have to start from scratch again. Does anyone know a possible solution for this? Now, my phone is an android 4.1.2 and it is rooted, otherwise I wouldn't have access to the data>data>game name folder>shared prefs folder. Back then I could modify the values of money or things of any game that allowed it but when I tried to do that again for the same game after it updated, I lost all my data and the values no longer take effect. And it's not just one game, it's doing it on all the games. Unfortunately, the handset I am using is unheard of, a CloudFone Thrill 430x and I have the Jellybean OS (version mentioned earlier). The file manager I used before is File Explorer and now Root Explorer, still same thing happening. I have noticed when using Root Explorer that when I change the permissions of the .xml file to read-only after my modifications (Root Explorer also created a backup of the .xml file), when I ran the game, there was no effect and when I checked out the shared prefs folder, my modification wasn't there and the backup of the .xml file was gone as well. What could be doing this?

If this was posted or covered in another topic or area, my apologies. Very hard to search via google these days because it gives you almost every single result, especially the unrelated ones. Again, apologies if this is a repost.