Wow... Games

Discussion in 'Samsung Fascinate' started by Bunachi, Dec 14, 2010.

  1. Bunachi

    Bunachi New Member

    Joined:
    Nov 3, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    This might not be important but I'm just letting you guys know. We (fascinate users) can't play hardly any of the new games that are out because or firmware is too old. Rocket bunnies and mana chronicles are two of them... I bought mana chronicles basically for it to tell me in a nice way that since I don't have 2.2 I can't play. Lol just making sure you guys know before you buy mana chronicles and to be hesitant before you buy a game cause I might not be able to play

    Sent from my SCH-I500 using DroidForums App
     
  2. Jamis0n

    Jamis0n Member

    Joined:
    Oct 24, 2010
    Messages:
    569
    Likes Received:
    2
    Trophy Points:
    18
    Ratings:
    +2
    Understandable for the games not to be compatible. I just feel bad for my girlfriend who has the moto cliq which is at 1.6. Almost all phones, which are able to be froyo, are at froyo already.

    8pened!