Wireless Tether?

Discussion in 'ChevyNo1' started by medic713, Jun 1, 2011.

  1. medic713
    Offline

    medic713 New Member

    Joined:
    May 25, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I've been running SS since I rooted my phone last July and I have to say I love it!!

    However, when I upgraded from 5.2 to 5.3 my wireless tether stopped working, giving me an error - something about wpa failed blah blah.

    When I rolled back to 5.2 the issue was gone and wireless tether worked like a charm.

    My question is, has anyone else had this issue and, more importantly, is it resolved in 5.4?

    Any help would be much appreciated. And Chevy, thanks so much for all you do for us!!
  2. tvBilly
    Offline

    tvBilly New Member

    Joined:
    Dec 23, 2009
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    The WEP protection mode doesn't work for me with 5.4. This is my first SS ROM, and I love it, but I can't get WEP to work when I wireless tether. Hold true for both Barnacle (which is what I always used in the past), and for Wireless Tether which was included in the 5.4 build.

    I had to change the encryption setup method setting to get tether to work without errors, but no WEP functionality (no padlock icon on machines I tether to the Droid).

    Billy
  3. coovee
    Offline

    coovee New Member

    Joined:
    Oct 1, 2010
    Messages:
    172
    Likes Received:
    0
    Trophy Points:
    0
    i get the same thing. i can use wifi tether but cannot use it with encryption :(
  4. ChevyNo1
    Offline

    ChevyNo1 Premium Member Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    0
    OK - I have no way to actually test if tethering is working since my D1 is not activated - however - I start tethering, and I get no errors - are you actually getting errors? 'Show Log' shows nothing wrong ...
  5. coovee
    Offline

    coovee New Member

    Joined:
    Oct 1, 2010
    Messages:
    172
    Likes Received:
    0
    Trophy Points:
    0
    yes it fails and the message in log shows date and time for the message:

    'activating encryption (wpa_supplication)...failed'
  6. medic713
    Offline

    medic713 New Member

    Joined:
    May 25, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    This is the same error I got.

    5.2 worked fine, the error came in 5.3, I haven't tried 5.4 yet...
  7. sranger
    Offline

    sranger New Member

    Joined:
    Aug 7, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    I found the same thing. I disable WEP and simply lock other users out with by turning access control on. This lets you only accept a connection from specific MAC addresses.

    It is not high security, but will keep the casual user off your phone....

    P.S. Be thankful, Verizon has blocked Wireless tether on most phones.....
  8. spc_hicks09
    Offline

    spc_hicks09 Premium Member Premium Member Developer

    Joined:
    Nov 7, 2010
    Messages:
    1,156
    Likes Received:
    33
    Trophy Points:
    48
    Location:
    Marion, OH
    Mostly just devices running GB though. I think STOCK GB.
  9. ChevyNo1
    Offline

    ChevyNo1 Premium Member Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    0
    Here is your fix, enter in terminal (or adb shell):

    chmod 777 /data/local/tmp

    No need to reboot - just stop and start tether - should work now!
  10. tvBilly
    Offline

    tvBilly New Member

    Joined:
    Dec 23, 2009
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    Worked for me with the included Wireless Tether, THANKS! (Though I used Root Explorer rather than terminal to change the permissions).

    I went into Wireless Tether's settings and put the "Encryption setup method" back to the default, which is "Auto" and everything works like it's supposed to, including WEP.

    (I am having a little trouble with Barnacle still, but I'm on the road and probably won't have time to troubleshoot why. I prefer Wireless Tether now that I've used it; my laptop connects much faster and more reliably than it did with Barnacle.)

    Keep up the OUTSTANDING work, and thanks for the great support.

    Billy
  11. tee00max
    Offline

    tee00max New Member

    Joined:
    Oct 3, 2010
    Messages:
    412
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    High Point, NC
    Says no file or directory when I type that into terminal, any ideas?

    Sent from my Droid using Tapatalk
  12. medic713
    Offline

    medic713 New Member

    Joined:
    May 25, 2011
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    When I enter this in terminal emulator I get the msg "Operation not permitted".

    Suggestions?
  13. RoyR80
    Offline

    RoyR80 New Member

    Joined:
    Jan 10, 2010
    Messages:
    299
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Detroit, MI
    Did you type in SU?
  14. ChevyNo1
    Offline

    ChevyNo1 Premium Member Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    0
    As mentioned (and I forgot this!) - type in su first, and then the above command. I always forget that when running in terminal, it is necessary.
  15. ChevyNo1
    Offline

    ChevyNo1 Premium Member Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    0
    Hmmm - try this:

    su
    /system/xbin/mkdir /data/local/tmp
    chmod 777 /data/local/tmp
Search tags for this page

android wifi tether activating encryption failed

,
chevyno1 tether
,
wifi teather error activating encryption
,
wifi tether activating encryption
,
wifi tether error activating encryption
,
wireless tether android showing errors