Wireless shuts off when screen sleeps

Discussion in 'Motorola Droid Pro' started by tennvol, Dec 31, 2010.

  1. tennvol
    Offline

    tennvol New Member

    Joined:
    Nov 23, 2009
    Messages:
    322
    Likes Received:
    1
    Trophy Points:
    0
    Noticed a new problem on my PRO. When I have wireless connected and I lock or let the screen sleep upon waking/unolocking wireless is deactivated and 3G is on. Wireless will eventually come back on and reconnect after 20-25 seconds. Is this supposed to happen or is there yet another issue with my PRO?
  2. DroidToro
    Offline

    DroidToro New Member

    Joined:
    Dec 20, 2010
    Messages:
    110
    Likes Received:
    0
    Trophy Points:
    0
    Are using any power management app? Juice defender does this for me but its by design.

    Sent from my DROID PRO using DroidForums App
  3. tennvol
    Offline

    tennvol New Member

    Joined:
    Nov 23, 2009
    Messages:
    322
    Likes Received:
    1
    Trophy Points:
    0
    Negative. Juice defender is installed but not active. I have the battery set to performance and to always sync

    Sent from my DROID PRO using DroidForums App
  4. google123
    Offline

    google123 New Member

    Joined:
    Sep 23, 2010
    Messages:
    472
    Likes Received:
    0
    Trophy Points:
    0
    tennvol, do the following:

    go to settings>wireless and networks>wifi settings>Press Menu Key>advanced>Wifi sleep policy....and set to either never, or never when plugged in. I believe the default was sleep when screen turns off.......
  5. tennvol
    Offline

    tennvol New Member

    Joined:
    Nov 23, 2009
    Messages:
    322
    Likes Received:
    1
    Trophy Points:
    0
    Didn't work.

    Sent from my DROID PRO using DroidForums App
  6. decapitor
    Offline

    decapitor New Member

    Joined:
    Dec 18, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Boston
    Same problem here

    I have the same problem as the OP. Wifi sleep policy set to never does not work. I had previously had juicedefender installed and then uninstalled it. My guess is that Juice Defender left some residual setting that messed up the wifi sleep policy.
  7. tennvol
    Offline

    tennvol New Member

    Joined:
    Nov 23, 2009
    Messages:
    322
    Likes Received:
    1
    Trophy Points:
    0
    I also notice that when the screen sleeps the 3g goes down to one bar but when I wake the screen the signal strength jumps. Im sure this doesn't help my battery.

    Sent from my DROID PRO using DroidForums App
  8. obutto
    Offline

    obutto New Member

    Joined:
    Nov 29, 2009
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    0
    This is normal. My Droid 1, 2, and Pro all do this.
  9. tennvol
    Offline

    tennvol New Member

    Joined:
    Nov 23, 2009
    Messages:
    322
    Likes Received:
    1
    Trophy Points:
    0
    Maybe its me.... my D1 didn't do this

    Sent from my DROID PRO using DroidForums App
  10. google123
    Offline

    google123 New Member

    Joined:
    Sep 23, 2010
    Messages:
    472
    Likes Received:
    0
    Trophy Points:
    0
    My Pro doesn't turn off the wireless unless I turn it off myself......
  11. tennvol
    Offline

    tennvol New Member

    Joined:
    Nov 23, 2009
    Messages:
    322
    Likes Received:
    1
    Trophy Points:
    0
    I wish I had that "problem" lol
  12. devator22
    Offline

    devator22 New Member

    Joined:
    Jul 20, 2010
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Mid-West United States
    My d1 does this. Doesn't matter what my wireless sleep policy is set to. Although, I don't consider it a problem so much because it saves battery. And I'm all about battery life. I've never had juice defender or any such thing installed, ever, and I'm using davrosMod for my rom, which is as stock as you can get while still calling it a custom rom. So this behavior is not something caused by an app or the rom.

    Sent from my brain, with the help of my Droid...
  13. decapitor
    Offline

    decapitor New Member

    Joined:
    Dec 18, 2010
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Boston
    it depends on battery mode

    I found that with wifi sleep set to never, the wifi still sleeps if the battery mode is set to "Maximum battery saver". If you set it to "Performace mode" the wifi will not sleep. Not that this is the most elegant solution but it does keep the wifi on if that's your number one priority.
Search tags for this page
andriod wireless off while locked
,
android screen off wireless
,
android turns off wireless
,

android wireless turns off

,
defender turns off wireless
,
my android wifi stops when screen goes off
,
my phones wifi turns off when screen closes
,
my wireless off when screen off
,
turn off wireless android lock screen off
,
turn off wireless off screen note
,
when my droid screen sleeps my app turns off
,
why android wireless is off after
,
wifi shuts off after
,
wifi turns off after sleep android
,

wifi turns off when phone locks android