Solved WiFi weirdness

Discussion in 'Android Tech Support' started by ChetPrynne, Feb 20, 2015.

  1. ChetPrynne

    ChetPrynne New Member

    Joined:
    Feb 20, 2015
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    Current Phone Model:
    Moto E
    Something strange is up with my new Moto E (KitKat 4.4.4).

    I went to configure WiFi on it and absentmindedly entered a password of "password" instead of the real password, and then saved it just as I realized my mistake. So then I long-tapped the connection, chose "modify network", corrected the password, and saved. But when I saved it this time it reported " failed to save network", and when it tried to connect I got an authentication error. So I ran "forget network" and tried to start from scratch.

    Here's where it gets strange. I tried connecting, but when I entered the correct password, the "SAVE" button stayed grayed out. No matter what I put in, I couldn't get the save button to activate, until I happened to enter "password" again, and then the save button activated. Of course, that does me no good. I saved it anyway and then tried to modify it again, but got the same "failed to save network" error. So I was going around in circles.

    But wait, it gets even stranger! I took my Moto to a secured hotspot away from home and tried to connect. Guess what? The only password the configuration widget will accept, even for a network it has never seen before, is "password"! The save button stays grayed out for anything else.

    I've tried setting things up through the third-party WiFi Connection Manager, and it also refuses to add any network whose password is not " password".

    What the Hell...?

    This is the sort of nonsense I've come to expect from Microslop, not the Google peeps.
     
  2. Miller6386

    Miller6386 Developer
    Developer

    Joined:
    Oct 22, 2011
    Messages:
    2,271
    Likes Received:
    1,575
    Trophy Points:
    1,363
    Location:
    Beer Tent Capital of The World
    Ratings:
    +1,719
    Current Phone Model:
    Note 4
    Twitter:
    CoreyFMiller
    Are you verifying that the Security type isn't set to something screwy like WEP or something?
     
  3. ChetPrynne

    ChetPrynne New Member

    Joined:
    Feb 20, 2015
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    Current Phone Model:
    Moto E
    It's WPA2 at home. I think it's at least WPA at the coffeehouse.

    Oh, and yes, I've rebooted several times.
     
  4. ChetPrynne

    ChetPrynne New Member

    Joined:
    Feb 20, 2015
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    Current Phone Model:
    Moto E
    I've even walked around trying to connect to random secured networks that I don't have login credentials for, and in every case, I can only set the connection up with "password" as the password. Otherwise the save button stays grayed out.
     
  5. Miller6386

    Miller6386 Developer
    Developer

    Joined:
    Oct 22, 2011
    Messages:
    2,271
    Likes Received:
    1,575
    Trophy Points:
    1,363
    Location:
    Beer Tent Capital of The World
    Ratings:
    +1,719
    Current Phone Model:
    Note 4
    Twitter:
    CoreyFMiller
    Try entering a different 8 letter password all lower case
     
  6. ChetPrynne

    ChetPrynne New Member

    Joined:
    Feb 20, 2015
    Messages:
    4
    Likes Received:
    1
    Trophy Points:
    3
    Ratings:
    +1
    Current Phone Model:
    Moto E
    Alright. Now I feel stupid. Yes, I was using a seven-letter password. So I put in a longer one at the WiFi router and now I'm up and running.

    Don't know what I'll do at the coffeehouse, though. Their password is "coffee". Life comes with bigger problems than that, bit it's annoying.
     
    • Like Like x 1
  7. grenefroggie

    grenefroggie Super Moderator
    Staff Member

    Joined:
    May 18, 2011
    Messages:
    975
    Likes Received:
    405
    Trophy Points:
    203
    Location:
    KY
    Ratings:
    +471
    Current Phone Model:
    Google Nexus 5
    I have found it is easier to forget the network completely and try connecting again. Editing the WiFi network seems to never work.

    WPA does not require an 8 character password. WPA2 requires at least 8 characters. When in doubt, forget the network and turn off WiFi for a few seconds then turn it back on.
     
    • Like Like x 3
  8. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,692
    Likes Received:
    3,549
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,037
    Current Phone Model:
    iPhone 7 Plus JB
    Glad you got it resolved.
     
Search tags for this page

android wifi failed to save network