WiFi - Secured "Open" Network, unable to login.

Discussion in 'Android Tech Support' started by art.vzqz, Apr 27, 2010.

  1. art.vzqz
    Offline

    art.vzqz New Member

    Joined:
    Apr 1, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hello all! I've searched high and low for a solution to this problem for months now but can't seem to find anything that works, so I figured I'd post-up here and see if anyone has any ideas that I haven't already tried.

    [Some Information]

    I am trying to connect to the WiFi at my university. The connection is open, so toggling the WiFi on my phone, Moto Droid btw, and selecting the network connects me; no problem there. From there, after opening up the browser, I am redirected to a page where I am required to enter my login credentials to access the internet.

    [The Problem]

    Prior to January of this year, I had no problem with any of this. However, the security certificate was replaced in January, and since then, I am unable to access the web page that allows me to enter my login credientials. I can still connect to the network, as it is open, and running the web browser still pulls up the page that informs me that I am being redirected to the login page, but from there, I get a "Web page not available" page and a popup error that reads, "Data connectivity problem - A secure connection could not be established."

    [Settings & Troubleshooting]

    I recently had to replace my phone due to unrelated problems, so a lot of what I’ve done up to this point is moot, but I will include it for completeness.

    Pop-up windows are not blocked.
    JavaScript and plug-ins are enabled.
    Cache, history, cookies and form data have all been cleared.
    Accept cookies is enabled.
    Show security warnings is enabled.
    Passwords have been cleared and are not being remembered.
    *Note – all of the settings above have been enabled/disabled in various combinations to no avail.

    Application Cache and Data has been cleared under Settings>Applications>Manage applications>Browser

    Factory reset has been performed.

    I found a web-based Certificate Installer here -> http://www.realmb.com/2010/01/android-certificate-installer/ and directly installed the new certificate, which I obtained from the IT Department at the university, but this was unsuccessful as well.

    Finally, hoping that the problem was somehow caused by the expired certificate being stored with my phone settings in my Google Account under Settings>Privacy settings>Back up my settings, I toggled that off but that didn’t help either.

    Oh, and using XScope, I’ve also tried changing my User Agent to IPhone, IPad, & PC in case the network only allows certain clients to access the network, even though the IT guys said it wouldn’t matter, but you guessed it, it didn’t work either…..

    So, any information that anyone else could offer would be really, REALLY, appreciated. Thanks in advance!

    -Art V
  2. JoeMofknDot
    Offline

    JoeMofknDot New Member

    Joined:
    Aug 10, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0



    hey i am having the same issues i am using moto droid CyanohenMod-6.0.0-Droid-RC3 rom before i rooted i had Verizon run the phone on there secure network and it seemed to run fine but when i tried it again on an unsecured network it failed to work again. Did you find a fix yet
  3. art.vzqz
    Offline

    art.vzqz New Member

    Joined:
    Apr 1, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    I wish I could give you a better solution. I was actually able to solve the problem, but only by upgrading to 2.2. I'm unsure what it was that caused the problem, or what changed from 2.1 to 2.2, but whatever it was, I fixed the problem.
  4. JoeMofknDot
    Offline

    JoeMofknDot New Member

    Joined:
    Aug 10, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Ok it must be something with my phone then because I'm using a rooted 2.2 rom and still have a problem. Thanks for the feed back
Search tags for this page

android hotel wifi redirect

,

android wont display secure network agreement

,

android wont redirect hotel wifi

,

arubanetworks securelogin wont load

,

data connectivity problem a secure connection could not be e

,
expired securelogin arubanetworks
,
galaxy note 3 not allowing me to login to public wifi due to
,
galaxy s4 will not connect to hotel wifi
,

hotel wifi login page not opening

,

samsung galaxy s4, hotel wifi

,

samsung s3 does not connect to open wifi hotel network

,

samsung s4 showing secured wifi as open

,

unable to connect wifi in samsung galaxy s4

,

unable to logon to open network browser

,
wifi opening login page not