1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

WiFi Scanning

Discussion in 'LithiumMod' started by JP 5.56, Jun 24, 2010.

  1. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    Not sure if this is really the right place but I believe it might have something to do with Kangerade as it didn't happen before hand..

    My phone in constantly turning on WifI and scanning. I don't want it to. I have 2 apps that I know of that can turn on/off wifi, locale and power manager. Locale is set to turn wifi on only when I am in my home. Power manager has all profiles set to "no change"

    Anyone have any ideas? I noticed it after kangerade 1.1 upgrade and trying out chrome 2 phone. Does that have something to do with it? I go to manually turn it off and it turns right back on until its done doing whatever its doing?
  2. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    Now it actually looks like turning my phone on from sleep is whats activating wifi. is that normal?
  3. Taegost
    Offline

    Taegost New Member

    Joined:
    May 16, 2010
    Messages:
    688
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Tampa Bay, Fl
    Are you using Juice Defender? I think the default setting for that is to disable wifi during sleep and turn it back on when it comes out
  4. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    Nope, don't have that one.
  5. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    It's been a problem with me also on every Froyo ROM except the original leaked versions (after applying P3Droid's kernels). JRummy's was working fine for a few days, then I started getting the same problem. At first it seemed to connect to my work wifi just fine, but nowhere else. Flashed BB, didn't work anywhere. Reflashed JRummy, now it works about 10% of the time. And yes, I wiped data, etc etc. I also have a few apps like Locale that can control wifi, but I was having this problem after a fresh install as well.
  6. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    I changed the wifi scanning interval in build.prop back to the Google-provided default (15) and now have wifi for the first time today! Let's see if this keeps up.
  7. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    How do you do that?
  8. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    If you have Root Explorer, open up /system/build.prop. You'll see a line that says wifi.supplicant_scan_interval = 90. Change 90 to 15, save and reboot. If you don't have Root Explorer, let me know and I'll list the adb commands. Or just buy Root Explorer!

    So far this change *seems* to have worked. I'll let it go for a day, and then, assuming everything's still good, I'll try some longer intervals.

    I'm not sure why this would fix the issue we're having, because my understanding is that this just adjusts the interval that Android scans for remembered APs when none are in range (and setting a longer interval theoretically saves battery, if you always have wifi turned on), but I've definitely had the best wifi connection in days!
  9. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    Well, no luck. Back to the same problem. At least now that source is out and Koush has something going (which I booted, then went back to JRummy for the time being) there's light at the end of the tunnel.
  10. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    I discovered last night that my wifi has stopped working all together. Its not that big of a deal as I only use it when at home and when at home I've got 3 computers to use instead of the droid but its nice to have.

    I'll check out this root explorer as I don't know how to use the sdk/adb stuff (I downloaded it but have not figgered any of it out yet)
  11. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    I've made another discovery:

    This all has something to do with /data/misc/wifi/wpa_supplicant.conf. I'm just not exactly sure what it is yet...

    Last night I wiped and resinstalled the original Froyo leak, which I had pretty good wifi with. I connected to my access point successfully, and copied /data/wifi/wpa_supplicant.conf to my sdcard.

    I then restored my JRummy backup, with which I could not connect to wifi at all. I copied wpa_supplicant.conf from my sdcard back to the /data path, and wifi came right up! Copied the "bad" one back to /data/misc/wifi, and wifi stopped again...

    I then compared the non-working wpa_supplicant.conf with the one that did. I could find ZERO differences. Permissions, group, owner were all the same. The data within the files were the same. Copied them to my PC and opened with Notepad+. I still could not see any difference between the two files.

    I then took the good file, deleted everything within it, and wifi came right up. Tried the same thing with the bad file... no wifi. Keep in mind I was replacing these files in recovery so as to not interfere with anything else.

    So, to sum it up, I now have working wifi, but have no idea why. It's been stable since last night with multiple APs. These files appear to be identical in every way, but obviously are not.
  12. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    I think JRummy might be interested in this info.

    Not sure what mine is doing, or if its related. I had flashed a couple different roms yesterday and last night and noticed that back to my original 2.1 root image, wifi good. Fresh install of Kangerade 1.1 after wipes and no wifi.
  13. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    Let's see if you can replicate my solution:

    Try installing FRF57, see if you can connect to wifi. If so, grab /data/misc/wifi/wpa_supplicant.conf, restore your Kangerade backup, and copy wpa_supplicant.conf back. I'd still suggest you get root explorer, but the adb commands would be:

    adb shell
    su
    cp /data/misc/wifi/wpa_supplicant.conf /sdcard/wpa_supplicant.conf
    exit

    Restore your backup, and then reboot to recovery (I'm assuming Clockworkmod recovery for this part).

    Select "Partition Menu" and select "mount /data" and "mount /sdcard"

    adb shell
    su
    cp /sdcard/wpa_supplicant.conf /data/misc/wifi/wpa_supplicant.conf
    chmod 666 /data/misc/wifi/wpa_supplicant.conf
    chown system wpa_supplicant.conf
    chgrp wifi wpa_supplicant.conf
    exit
    adb reboot

    Test out wifi!

    Let me know how it works.

    EDIT: made a couple changes to ADB commands (chown and chgrp)
    Last edited: Jun 25, 2010
  14. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    I did get root explorer but no access to wifi where I am so I'll have to give it a go later.
    Last edited: Jun 25, 2010
  15. Bxrider117
    Offline

    Bxrider117 New Member

    Joined:
    Dec 7, 2009
    Messages:
    455
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Back in NYC 4 good!!!
    I am on vacation in the Domincan Republic and I am running the latest JRummy Froyo rom and I am having the same issue with my Wifi always scanning. I just thought is was the resorts cheap wifi service. It is interesting to see that other people may be having the same problem.

    When I got here my wifi just kept saying it was scanning. Then I went back to my stock nandroid back up and reloaded Kangrade with a different kernel and I was able to get service, but it constantly jumps from connected to scanning. I will make the neccessary adjustments when I get back to the states in a few days.
  16. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    Does not work for me.

    I loaded up FRF57 and tried out Wifi - it worked. I grabbed the file, reloaded my back up and put the copied the file in.

    Turn on wifi and it says "Error" where it would normally say connected.

    Reboot the phone: now when trying to start wifi it either FCs or turns itself off.
  17. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    Shoot. Thought I was on to something. You did the chmod, chown, and chgrp commands as well?

    Since you're still having problems, can you flash this kernel and see if it helps? New wlan driver built from source:

    http://dl.dropbox.com/u/6011176/jdlfg1000.v32.2.0.zip
  18. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    No commands, I did it through Root Explorer, is there a way to do those through root explorer?
  19. JP 5.56
    Offline

    JP 5.56 New Member

    Joined:
    Feb 23, 2010
    Messages:
    593
    Likes Received:
    10
    Trophy Points:
    0
    The kernel did not make a difference either.
  20. roll3r
    Offline

    roll3r New Member

    Joined:
    Jan 13, 2010
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    You can change the permissions in Root Explorer, but not the owner/group. Long-press wpa_supplicant and select permissions. Make sure that User Read, User Write, Group Read, and Group Write are checked. However, since the ownership and group are probably wrong, go ahead and check all the boxes!

    You should also download "Android Terminal Emulator" from the Market. This will let you run commands right on your phone, so no ADB needed.

    BTW, still haven't had any wifi issues since doing this!
Search tags for this page
android set wifi scan interval
,
android wifi scan interval
,
android wifi scanning connecting disconnected
,
android wifi supplicant
,
change build.prop wi-fi scan
,
disable wifi scans locale
,
how to turn off wi-fi scanning on an s4
,
missing wifi.supplicant scan interval
,

wifi scan interval

,
wifi scan interval android
,
wifi scan interval setting
,
wifi scanning driod
,

wifi supplicant scan interval

,
wifi. supplicant scan
,
wifi.supplicant scan interval