wifi and smart action

Discussion in 'Motorola Droid Bionic' started by KenWK, Aug 28, 2013.

  1. KenWK
    Offline

    KenWK New Member

    Joined:
    Sep 10, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Hello!

    I have a smart action that turns off my data and wifi when the screen goes off. Works GREAT for battery life but I'm having trouble with the wifi part of it.

    When the screen it comes back on and the smart action turns the data and wifi back on, the wifi is crap. The wifi signal indicator will show only the very bottom tiny dot, or it won't connect at all. Sitting here just now, for instance, my Bionic is showing just the very bottom of the wifi signal indicator but my tablet (a cheapo tablet at that!) is showing one stripe shy of full bars. This happens regardless of how close I am to the wireless modem.

    Sometimes it won't connect at all. Going into the wifi settings, selecting the network and hitting "Connect" right away, without any hesitation, gives a message "Failed to connect to network." If I restart the phone the wifi comes on as it should.

    Setting this smart action works GREAT for battery life, too bad the wifi doesn't come back as it should.

    Any else seen this?

    Thanks a bunch!
    Ken
  2. leeshor
    Offline

    leeshor DF Super Moderator Staff Member

    Joined:
    Jan 30, 2012
    Messages:
    2,988
    Likes Received:
    402
    Trophy Points:
    83
    Location:
    Norcross, GA - USA
  3. KenWK
    Offline

    KenWK New Member

    Joined:
    Sep 10, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    So, do you know? Does that simply not work with the smart action? A known bug, perhaps?

    I guess I'll disable the smart action and give this a try.

    Thanks
  4. KenWK
    Offline

    KenWK New Member

    Joined:
    Sep 10, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Nope, NFG. Auto Airplane Mode did the same thing. So, apparently it doesn't have to do with the smart action.

    Thanks for sending the suggestion.

    Ken
  5. jhom
    Offline

    jhom Member

    Joined:
    Mar 28, 2010
    Messages:
    365
    Likes Received:
    8
    Trophy Points:
    18
    Location:
    Dallas, TX
    This has happened to me. Try forgetting the WiFi connection and then reconnect. Sometimes you need to refresh the connection.
  6. leeshor
    Offline

    leeshor DF Super Moderator Staff Member

    Joined:
    Jan 30, 2012
    Messages:
    2,988
    Likes Received:
    402
    Trophy Points:
    83
    Location:
    Norcross, GA - USA
    You may also want to check the WiFi issues link in my sig. Making a change in the router might do the trick.
  7. KenWK
    Offline

    KenWK New Member

    Joined:
    Sep 10, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    Thanks guys!

    Maybe I'll give the forgetting and re-connecting thing a try, its easy enough to do. The odd thing is that its sporadic, and happens with 2 different networks / routers, home and work.

    FYI: I've removed the wifi from the smart action while trying to figure out what's going on with the connection.

    Maybe some other Bionic owners can confirm this (or not): I looked through the wifi settings again and in the "Advanced" area there is a "Keep Wi-Fi on during sleep" setting. This would imply that when the phone sleeps the wifi would turn OFF, but that doesn't seem to be the case. I include the wifi in the smart action for when the display changes for that to happen. I currently have that setting on "Only when plugged in" and its not currently plugged in. Am I misinterpreting what this setting is supposed to do?

    Again, WITHOUT wifi being turned off by the smart action, I turned the screen on earlier to find the wifi NOT showing in the status area (at the top of the screen) so I went and turned the wifi off, then on again. Now it seems to be staying on while the screen is off because it shows a good connection as soon as I turn the screen on.

    I'm going to try and leave the wifi on for a while to see what happens when I come and go, in and out of range of the networks.

    Thanks again for the suggestions.

    Ken
Search tags for this page
android wifi or data smartaction
,
auto-connect wi-fi and smartaction
,
lg optimus g pro wifi won't turn on -review
,
motorola razr m hesitates wifi mode
,

optimus g pro won't power off

,
why wont my phone connect to 4g