Wi-Fi Sleep on "When Screen Turns Off", yet packets still go through Wi-Fi?

Discussion in 'Motorola Droid 3' started by josby, Aug 3, 2011.

  1. josby

    josby New Member

    Jun 30, 2010
    Likes Received:
    Trophy Points:
    In the quest to improve my D3's battery life (I always hit 10% after 16-17 hours on battery), I tried changing the Wi-Fi Sleep policy from what it was on - "Never" - to "When screen turns off" instead. The description for the Wif-Fi Sleep policy is "Specify when to switch from Wi-Fi to mobile". So, I would expect that once I turn my screen off, it would switch to 3G, right?

    But, I was suspicious because whenever I turned the phone back on, the Wi-Fi was right there ready to go immediately. I'm the network admin at my company, so I set up a packet capture (using Wireshark) on the switch port our Wi-Fi router is on, and set it to only show packets with the IP address assigned to my phone. I then turned the screen off and waited. Sure enough, I still saw data moving through. For example, after my phone's screen had been off for about 10 minutes, I sent an email to myself from my PC...sure enough, within a few seconds, I see some packets going back and forth between my phone and our mail server via the Wi-Fi connection.

    If this sleep policy works as expected, that shouldn't happen - the new email should've come in through 3G data (FWIW, I'm in a strong signal strength area, so no issue there).

    Anyone else care to duplicate this and see if they have the same problem? Anyone know for sure if this setting works correctly on other Android phones? Thanks
Search tags for this page

android disable packet when screen off


htc rezound wifi turns off sleep