Why does my Moto Z "Contact" appear different than my online Google Contacts & iPhone Contact?

Discussion in 'Android Support' started by King Bengals, Jan 23, 2017.

  1. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    I'm trying to sync my old iPhone Contacts onto my new Moto Z. I went to Setting/ Accounts/ Google/ my gmail account & I see my contacts were synced 5 mins ago. I switched it off then back on to force the sync again. Then I go to my gmail account on my laptop & open Contacts. The Contacts in there seem to be right & match up with what I see in my old iPhone Contact. But when I click on the Contact App on my Moto Z it doesn't match either of the other "Contacts" lists. More irritating it has multiple entries for the same name. That is not how those contacts show up on my PC or my iPhone. What am I doing wrong?
    Thanks!
     
  2. King Bengals

    King Bengals Member

    Joined:
    Jan 10, 2017
    Messages:
    46
    Likes Received:
    23
    Trophy Points:
    8
    Location:
    New York City
    Ratings:
    +23
    Current Phone Model:
    Moto Z Force -32G.
    I think I fixed it. I had to "Remove" both gmail accounts then I reinstalled the primary account & now it appears to look right. I'm doing to do some editing to some contact to see if the changes sync correctly.
     
  3. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,531
    Likes Received:
    7,090
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,437
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Also, not sure if it's still the case, but Moto used to have their own contacts account. You could choose to save to the phone/your Moto account instead of your Google account. It was a pain back in the day.

    Anyway, in your contacts app, there should be an option in the settings to select where to display contacts from. That might also help your issue. Ie. Make sure it's only displaying contacts from one Google account or wherever you're sure your contacts are correct.