Weird LTE speed results?!?! Battery makes the difference?

Discussion in 'Samsung Galaxy S3' started by huskur, Nov 15, 2012.

  1. huskur

    huskur Senior Member

    Joined:
    Dec 3, 2009
    Messages:
    1,869
    Likes Received:
    36
    Trophy Points:
    78
    Location:
    Lower Delaware
    Ratings:
    +36
    OK. So this is very strange. With the stock battery in I am getting a from 8000- 11000 kbps down and 2000-4000 kbps up.

    I purchased an extended battery (from China) and installed it. In the EXACT same place in my office with the new battery I am getting 15000-20000 kbps down and 8000-13000 kbps up.

    Now I have retested both batteries and still get these results. Is this just absolutely strange? WTF
     
  2. EricUnLtd

    EricUnLtd Member

    Joined:
    Feb 2, 2011
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Charlotte, NC
    Ratings:
    +0
    Be careful with those extended batteries from China.
     
  3. huskur

    huskur Senior Member

    Joined:
    Dec 3, 2009
    Messages:
    1,869
    Likes Received:
    36
    Trophy Points:
    78
    Location:
    Lower Delaware
    Ratings:
    +36
    Just switched batteries again and tested. Same results.
     
  4. jackiescivic

    jackiescivic Senior Member

    Joined:
    Feb 10, 2011
    Messages:
    1,082
    Likes Received:
    286
    Trophy Points:
    83
    Location:
    Muskego, WI
    Ratings:
    +289
    Maybe it's just me, but I don't understand what your battery has to do with getting speeds
     
  5. huskur

    huskur Senior Member

    Joined:
    Dec 3, 2009
    Messages:
    1,869
    Likes Received:
    36
    Trophy Points:
    78
    Location:
    Lower Delaware
    Ratings:
    +36
    When I put the extended battery in my speeds greatly increase for some reason. No rhyme nor reason that I can think of but it does for some reason.