Weatherbug Quit working after update yesterday

Discussion in 'Droid RAZR Support' started by joezek, May 3, 2013.

  1. joezek

    joezek Member

    Joined:
    Aug 20, 2010
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    PSL, FL
    Ratings:
    +0
    I have Weatherbug Elite that I paid for. It was working perfectly with no problems for about the last two years. Now yesterday they updated it and all it does is freeze up and close every time I try to look at the radar. Also, the radar screen has a sentence that reads "Unknown issue with Google Play services". I use the Eclipse ROM if that matters.

    Has anyone else had this problem, or do you have an idea how to fix it or just reinstall the old version of weatherbug and turn off the updating?

    I've already tried clearing data, clearing cache and reinstalling several times with and without rebooting in between each reinstall. I've also tried the free version of weatherbug, (which is also updated version) and it doesn't work either.

    JOE
     
  2. MasterGadgets

    MasterGadgets Member

    Joined:
    Aug 21, 2012
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Pensacola, FL
    Ratings:
    +0
    It sounds like an issue with your phone. Something in the ROM perhaps?
    Mine works fine after the update, but I'm on the stock ROM.
     
Search tags for this page
google play services for weatherbug radar
,
google play services weatherbug
,
google play weatherbug
,

unknown issue with google play services

,
unknown issue with google play services weatherbug
,
weatherbug app for android unknown issue with google play se
,
weatherbug google play services
,
weatherbug google services
,

weatherbug radar not working

,

weatherbug unknown issue with google play services