Want the milestone gallery back? here's how I did it..

Discussion in 'Android Hacks and Help' started by gnome_sayin, Mar 12, 2010.

  1. gnome_sayin
    Offline

    gnome_sayin Member

    Joined:
    Jan 15, 2010
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Since updating to use Pete's ESE53 builds, I've been sorely missing the Milestone Gallery.. I am not all that experienced with hacking.. so it has taken me a while to figure out how to get it back..

    Ok, this might not be the most elegant way to do it, but it worked! (so far anyway)

    Step 1. Go here and read this thread: [release] Milestone multitouch Gallery for 2.0.1 v1.0

    Download the MediaGallery.zip from the link provided and extract both files (com.motorola.aui and MediaGallery.apk) to your PC in the /tools directory for your ADB install. In my case it was in D:\android-sdk\tools.

    Step 2. You need to get the "platform.xml" file from the following path on your phone: /system/etc/permissions so that you can edit it on your PC.

    I did this by using Astro. I navigated to the /system/etc/permissions directory and did a copy, then pasted it to the root of my SD card.

    Step 3. Connect your phone to the PC via your USB cable and move the "platform.xml" file from your SD card to the /tools directory on your PC, where you copied MediaGallery.apk and com.motorola.aui.jar in step 1.

    Step 4. Using whatever editor you choose, open "platform.xml" and at the bottom of the file, add the following:
    <library name="com.motorola.aui" file="/system/framework/com.motorola.aui.jar"/>

    You'll probably see a couple similar entries, just add another.

    save the file and close.

    You should now have the three necessary files residing in your /tools folder:
    MediaGallery.apk
    com.motorola.aui.jar
    platform.xml

    Step 5. Shut down your phone and power it up into SPrecovery mode.

    CREATE A BACKUP!!! I'm not responsible for hosing your phone!! :p

    Step 6. You did create a backup didn't you??

    In SPrecovery, go into the mount options and choose to mount the system.

    Step 7. On your PC open a cmd prompt and navigate using dos commands to the /tools folder. Then, type the following 3 commands:
    adb push platform.xml /system/etc/permissions
    adb push MediaGallery.apk /system/app
    adb push com.motorola.aui.jar /system/framework.

    after each push command, you should see the results of the file push.

    Step 8. unmount the system, and reboot your phone!

    It worked well for me.. I hope it does for you too!

    Now... if anyone has any modificaitons to the instructions, I'm all ears.. I'm clunky at this stuff at best! :)

    Good luck!

    Jamie
     
Search tags for this page

milestone x get gallery back