video recording problems with apps

Discussion in 'Droid Bionic Tech Support' started by DailyRoads, Sep 25, 2011.

  1. DailyRoads

    DailyRoads New Member

    Joined:
    Dec 28, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello all,

    I am the developer of a dashcam app (DailyRoads Voyager) which has been used on almost all the Android phones since the G1. Only on the Droid Bionic it can't seem to record properly at any resolution. I've been told the resulting videos contain green/purple lines, and this happens with other video apps, as well.

    Was anybody successful at recording with any app besides the stock camera app? If so, do you know what resolution/encoder combination was used? If you can send me a video, I can look at the headers to find out.

    Thanks,
    Robert
     
  2. hobodan

    hobodan New Member

    Joined:
    Nov 17, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello!

    I am having this problem with the droid bionic. I don't know what type of video the device supports/settings it needs, but I am willing to debug stuff for you! I can record videos with the stock camera app and send them to you. I can also send you a file with what I am seeing. I can try testing different video types as well. So far I have tried just the HQ quality, Custom Quality at 1080p with the h.264 and mp4.

    Thanks,
    Dan
     
  3. DailyRoads

    DailyRoads New Member

    Joined:
    Dec 28, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi Dan,

    Thanks for the help offer, but since my post here, I had the opportunity to test remotely on a Bionic. Regardless of what I changed in the code, I could not make it work.

    Recently I saw this comment on the Market: "Awesome job! World great on my DroiD Bionic, HTC Thunderbolt and also my Droid X! Bionic Android 2.3.4 honeycomb, Thunderbolt/Droid X Android version 2.2.3 (Froyo)"

    So, maybe the answer is in Android 2.3.4? What version do you have on your phone?

    Thanks,
    Robert
     
  4. hobodan

    hobodan New Member

    Joined:
    Nov 17, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hello Robert,

    Bummer! I wonder how that guy got it to work because I have the same version, 2.3.4. Maybe he did not actually check the files themselves. Mine is rooted however. Maybe when stable versions of other roms might help. Just have to wait for one to show up I guess.

    Thanks,
    Dan
     
  5. Calla969

    Calla969 Member

    Joined:
    Nov 9, 2009
    Messages:
    157
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    I really hope you can figure this out. I wanted to use the app and had the same problems. Glad to see that you're working on it. I'd be happy to help if you need testing or anything simple.
     
  6. hobodan

    hobodan New Member

    Joined:
    Nov 17, 2009
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Robert,

    I noticed the App, AutoGuard is able to record successfully. Would you like me to send you some sample files?

    Thanks,
    Dan
     
  7. razruser

    razruser New Member

    Joined:
    Nov 10, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    re:

    I have the same problem. AutoGuard records just fine but the other handfull of similar recording apps that I tried have the green/purple striped video.

    I have the new Razr.
     
  8. DailyRoads

    DailyRoads New Member

    Joined:
    Dec 28, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Maybe these problems will finally end with the new Motorola update. I saw this comment today on Android Market:

    "I did have to update my Droid Razr. After the 2/13/12 update from Motorola the video works great (before the video was all green lines)."


    Anybody else got the update? If so, please report back whether you still see the green/purple lines.

    You can check what update is scheduled for your area: https://forums.motorola.com/pages/00add97d6c
     
  9. danakes

    danakes New Member

    Joined:
    Feb 17, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I love your program. I hate the green and purple video. Although most similar programs have the same problem on my Bionic, one, A-Lap Recorder, works fine. Hopefully, this will allow you to figure out your problem. I would love to have yours work properly.

    Dan

    Sent from my DROID BIONIC using DroidForums
     
  10. DailyRoads

    DailyRoads New Member

    Joined:
    Dec 28, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi Dan,

    What Android version do you have on your phone? Maybe there is a new 2.3.X update available, it doesn't have to be the 4.0 update.

    Robert
     
  11. danakes

    danakes New Member

    Joined:
    Feb 17, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    2.3.4

    Dan
     
  12. DailyRoads

    DailyRoads New Member

    Joined:
    Dec 28, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I heard back from 2 users, who updated their phones to Android 2.3.6. Both say the videos now record properly :)
     
Search tags for this page

android troubles with video record

,

android video not recording properly troubleshooting

,

android video recording problem

,

autoguard not working droid

,

dailyroads forum

,

dailyroads voyager droidx

,

dailyroads voyager not recording

,

dailyroads voyager not recording on custom

,

droid bionic 2.3.4 video problems