Verizon KitKat Update Kills Data?

Discussion in 'Samsung Galaxy S4' started by RyanPm40, Apr 28, 2014.

  1. RyanPm40

    RyanPm40 Active Member

    Joined:
    May 3, 2010
    Messages:
    897
    Likes Received:
    96
    Trophy Points:
    43
    Ratings:
    +136
    For some reason, my 4GLTE or 3G icon keeps randomly greying out, and no texts will send/chrome will say I'm offline. But it constantly greys out/comes back like every 20 seconds. This seems to mostly happen randomly when transitioning from Wifi to data. Right now the only solution seems to be rebooting it and crossing my fingers.. I just took the SIM out/in, hopefully that helps. I was wondering if anybody else has noticed a similar occurance after updating?

    EDIT

    Seems like my texts never want to send when I'm connected to Wifi; the 4g icon stays grey with the Wifi Bars staying lit up >_>
     
  2. jspradling7

    jspradling7 Active Member

    Joined:
    Apr 7, 2012
    Messages:
    801
    Likes Received:
    214
    Trophy Points:
    43
    Ratings:
    +214
    No, I just upgraded one this morning and it seems fine. But, I did do a factory reset on it after it upgraded.
     
  3. RyanPm40

    RyanPm40 Active Member

    Joined:
    May 3, 2010
    Messages:
    897
    Likes Received:
    96
    Trophy Points:
    43
    Ratings:
    +136
    Yeah, i was hoping I would be able to avoid a factory reset, but I may have to resort to doing a reset/restore with Kies later if the problem doesn't go away. It seems to be behaving better now, but time will tell I guess. Anyone know if an OTA upgrade has ever been known to mess up the SIM card? I'm wondering if it somehow got fried and can't make the connection fully anymore
     
  4. jhom

    jhom Active Member

    Joined:
    Mar 28, 2010
    Messages:
    411
    Likes Received:
    33
    Trophy Points:
    28
    Location:
    Dallas, TX
    Ratings:
    +36
    Before resetting, you might try turning off the S4. Pull the battery and sim card. Restart the S4 without the sim card. Then turn off the S4 and reinsert the sim. One of my S4 (I have 3) was acting funny after the update. The 4g would randomly come on and stay on for a while when wi-fi was on. On the other S4, the 4g stayed off when wi-fi was on. After starting the S4 without the sim, all is fine.

    Update: Apparently, I had to things going on. The sim not seated thoroughly that was solved with reseating the sim. The other thing had to do with the 4g icon being greyed out on one S4 and the 4g icon being on while wifi was on. The bloatware Caller Name Id app appears to be the culprit affecting the 4g icon. With the app "turned off," the 4g icon is consistently off when wifi is on (my preference). With the app left "on," the 4g icon will randomly light up or gray when wifi is on. Why Caller Name ID does this is well beyond my understanding.
     
  5. RyanPm40

    RyanPm40 Active Member

    Joined:
    May 3, 2010
    Messages:
    897
    Likes Received:
    96
    Trophy Points:
    43
    Ratings:
    +136
    Thanks man, Ill give it a shot if the problem comes back; so far so good after just reinserting my SIM (I didn't power up with it taken out, though)
     
Search tags for this page
losing 4g verizon after android update
,
lost 4g after kitkat
,
samsung galaxy s 4g overheating
,

samsung galaxy s4 verizon kit kat overheating

,
verizon 4g with a bar crossed
,

verizon galaxy s4 shows 4g and wifi

,

verizon kitkate update s4 caller id

,

verizon s4 lost 4g after kitkat upgrade

,
verizon samsung galaxy s4 acting weird
,

verizon wireless samsung galaxy s4 overheating after update